[SOLVED] Gigabyte B560M DS3H - inaccessible boot device

Jan 27, 2022
My PC was running just fine. I was using a Samsung 870 evo SSD as my system drive. Then I turned off my PC and connected a WD HDD for storage facility. When I turned on the PC, it shows me 'inaccessible boot device' error.

I have checked BIOS. It shows both the SSD and the HDD there - only SSD as bootable. It's not a SSD issue. I have tested that SSD in my other PC with a Gigabyte Z68MA DS3H motherboard, and Windows 10 in that SSD boots up completely fine.

I also tried to do windows installation, but don't see the SSD or HDD during the installation. Instead of two ram sticks, I tried with one, but no luck there. I enabled CSM support, played with legacy and UEFI boot mode, also didn't work.

Btw, I had this same problem when I connected the SSD for the first time. I don't remember how I solved it back then. 😑

Here's my PC's configuration:
Gigabyte B560M DS3H
Core i5 11400
Corsair Vengeance LPX 8GB 3200MHz (x2)
Samsung 870 EVO 250GB 2.5 Inch SATA III Internal SSD

Could someone please help me to find out what's wrong with the system?