Question Gigabyte G1 Z5S and RAM problem

mickelhponekyaw

Commendable
Aug 30, 2018
4
0
1,510
0
I have a problem with my motherboard.
Every time before open my PC, I need to rub RAM with rubber and clean RAM slot. After that put it back and turn on PC it's will go ok. Otherwise PC won't open and even bios setup didn't see it and no error sound.
What is the main problems, I think north bridge getting problems and its time to change motherboard.

Here is my specification
CPU: i7 4790s
MB: Gigabyte G1 sniper Z5S
RAM: Corsair Vengeance pro ddr3 1333MHz
GPU: RX 550 XT
PS: EVGA Gold 80+ 850W

Please give me your opinion and problems solving. Thank you
 

Lutfij

Titan
Moderator
Have you tried disconnecting the Chassis(and it's innards) from the wall and the monitor and your peripherals, then pressing and holding down the power button for 30 seconds, later to reconnect the system to display, power and peripherals? If that works, it's highly possible that you're suffering from a grounding issue. BIOS version for your motherboard at the time of writing?

Another point to note, you should be on DDR3-1600MHz 1.5v rams as opposed to DDR3-1333MHz sticks. How old is the PSU in your build?
 

mickelhponekyaw

Commendable
Aug 30, 2018
4
0
1,510
0
Have you tried disconnecting the Chassis(and it's innards) from the wall and the monitor and your peripherals, then pressing and holding down the power button for 30 seconds, later to reconnect the system to display, power and peripherals? If that works, it's highly possible that you're suffering from a grounding issue. BIOS version for your motherboard at the time of writing?

Another point to note, you should be on DDR3-1600MHz 1.5v rams as opposed to DDR3-1333MHz sticks. How old is the PSU in your build?
UPS: is round about 1 and half year old.
 

ASK THE COMMUNITY