Question GPU randomly gets stuck at 100% in task manager and slows computer down significantly

Mar 22, 2019
11
1
15
0
I've had this problem for about a week and I've been trying to figure it out. The problem is, I notice my computer starts having huge lag spikes when watching Youtube and playing games at the same time. I check task manager and it says that my GPU is at 100% even when it says that nothing is using it. Everything is at 0% and temperature is normal, no viruses found when using Malwarebytes, F-Secure and Windows Security. I suspect it has something to do with Google Chrome, Roblox or some kind of a cryptocurrency mining virus that has been hidden really well. If anyone knows any ways i could fix this or if anyone knows what could cause this, please let me know! Thanks!

Specs:
CPU: i7-3570
GPU: Asus GTX 1060 6GB
RAM: 16GB DDR3
Motherboard: Gigabyte Z77X-UD3H
 

Lutfij

Titan
Moderator
Always list your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

Are you on the latest BIOS update for your motherboard? have you tried uninstalling and reinstalling GPU drivers with the latest found off Nvidia's site? I'm assuming you're on Windows 10, if so, which version of the OS are you on?
 
Mar 22, 2019
11
1
15
0
Sorry for the late reply, I didn't list all the specs because I was unsure of some and didn't know how to check all of them as my pc is a little old.
Not sure about BIOS since I've never used it and don't know how.
I uninstalled all the Nvidia drivers from my pc and I'm currently using Window's own drivers. That fixed the problem with GPU but something kind of unexpected happen.
The problem suddenly appeared on CPU. It went to 100%, almost totally freezing my computer, just the same way as the problem with GPU did.
Also, about the OS, I'm using Windows 10 Home, Version 1809, OS 17763.379
 

ASK THE COMMUNITY

TRENDING THREADS