Question Graphics Card is Spinning Fast, No Display When Connected HDMI Port on GPU but Display is On when connected to Motherboard's HDMI

Apr 14, 2021
3
0
10
0
When I was Playing It Takes Two, Dispay suddenly went off but the sound came through for a moment, I thought It was HDMI cable's loose connection and I tried adjusting It , but nothing happened , then I tried a different HDMI cable then also nothing happened and showed no signal , after that I connected my HDMI cable to Motherboard's port and It worked just fine , I saw some videos and tried to uninstall and reinstall driver , but after uninstalling my PC doesn't recognize my graphics card but my GPU is working and the fan is spinning louder than usual in an consistent speed , what should I try? , what's wrong with my PC? , should I try using DP port?
PC Specs - Gigabyte B150M-D3H
RX 470
8 GB RAM
450W power Supply
i3 6100
 
Apr 14, 2021
3
0
10
0
Do you have a diffrent working psu to test with as that is not a reliable psu
No I don't have another one..... I'm currently using with my monitor connected to Motherboard....but the gpu fan is consistently loud..... what are the causes of using non reliable psu
 

Jacozeelie

Respectable
Mar 1, 2019
652
86
1,970
1
The obvious is hardware errors, specialy gpu, pc crashes unexpectedly and restarts under load. Components not working as they should, not getting any display as to not enough power. Can you maybe test the gpu in a diffrent system, a friend maybe or pc shop
 

thelemon27

Reputable
Oct 4, 2017
17
0
4,520
1
It might be that the 6 pin or 8 pin power connector is not properly seated or is faulty. I've observed the exact thing you're describing happen when a graphics card is not plugged in.
 

ASK THE COMMUNITY

TRENDING THREADS