Question GRUB stopped working on different systems

GuiRitter

Distinguished
Nov 2, 2013
13
0
18,510
0
Hi everyone.

Refer to this thread for context.

In 2020's Black Friday I purchased an Intel NUC8i7HNK. In it, I installed 2 250 GB Samsung 860 EVO SATA M.2 V-NAND SSDs. In the first one, I installed Windows 10. In the second one, Xubuntu 20.04. All using UEFI and GPT.

All worked wonders for the first few times but how surprised was I when this system started having the same issue as the laptop in the previously linked thread. Hopefully I also still could boot using a pen drive with Super Grub2 Disk so I left it at that.

However, some time ago the same laptop stopped to boot from the pen drive. All it says is

Code:
No Boot Device Found. Press any key to reboot the machine_
or

Code:
No bootable devices found.
Press F1 key to retry boot.
Press F2 key to reboot into setup.
Press F5 key to run onboard diagnostics.
I messed with the boot options and found someting out that worked. First I changed Boot List Option from UEFI to Legacy. Then, whenever I wanted to boot, I had to press F12 and select the pen drive from the options listed under UEFI. Then it would boot into Super Grub2 Disk which allowed me to boot into the OS that I wanted. Ok, it's an additional annoying step but I can live with it.

However, as if that wasn't enough, about 2 weeks ago that stopped working too. Now I really can't boot into Windows or Linux anymore. So I want to fix it once and for all before it happens with the NUC...

Today I decided to do some more tests. I installed Xubuntu 20.04 in another pen drive and tried to boot the live distro. At least that is still working! From there I tried to reinstall/update GRUB. I followed these steps and despite executing them successfully nothing changed.

What else can I do?

Thanks in advance.
 

ASK THE COMMUNITY

TRENDING THREADS