Question HDD causing boot loop during post

deathstroke173

Reputable
Oct 11, 2017
7
1
4,515
0
Hello, I have a problem with a 2.5-inch 1TB WD BLUE HDD causing boot loop during post (i have tested it on 3 other system and its doing the same thing). I managed to connect it to my pc while its already on i can read and write files to it with no problem i tried to remove all partitions and fast format it but the problem still persists (during writing this question i am waiting for the "slow formatting " but i have the feeling this wont fix it). The HDD is quite new its 2 years old and has been used for around 2k hrs . I used crystal mark to check it and doesn't show any errors. Any ideas how can i fix it or its time for a new one.
Thanks.
 

deathstroke173

Reputable
Oct 11, 2017
7
1
4,515
0
If your boot drive is GPT, using both MBR and GPT on the same computer could be causing your problem. Either try converting the MBR drive to GPT or check in your BIOS to see if there is a Boot Mode setting for "UEFI and Legacy".

The HDD was first in a laptop with only one HDD and was working without a problem until it started to boot loop on post (i reset the bios a couple of times didn't help). But i will try with that option and see if it makes a difference. Thanks!
 

deathstroke173

Reputable
Oct 11, 2017
7
1
4,515
0
I didn't find the option in bios but after the "slow formatting" i plugged in the HDD in the laptop and this time booted without a problem i am installing windows right now . I guess there was a virus or corrupted windows boot file, also converted the drive to GPT bcs windows didn't let me to install it on MBR partition but that was after the successfully boot. Thanks for the help.
 
Reactions: rocktalkrock

ASK THE COMMUNITY