[SOLVED] HDD Not Detected

Dec 21, 2021
7
0
10
0
I just got a brand new 2 tb HDD that is connected via brand new SATA data cable and powered via brand new SATA power cable. I have switched SATA data cables and switched which ports it is plugged into on all the ports available.

The hard drive spins but I checked and bios is not picking it up at all even after restarting several times. My PC starts just fine so I don't believe it is a power issue.

I am at a complete loss and have no idea what else it could possibly be.
 
Dec 21, 2021
7
0
10
0
Who do you think I should contact for more help on this. The motherboard company or someone else? It's an MSI z390 gaming pro carbon
 

xoutostrela

Reputable
Dec 19, 2017
47
1
4,565
9
You probably haven't formatted the HDD. When you buy any new Storage it's unformatted so the Windows cannot identify it as to what it is.
Go into Start (down in the windows icon) search for <Disk Management>
All your Storages should be on Blue color except for your new one, the unformatted ones are in black color, right click on it and click on format, follow the steps and just press next to pretty much anything that comes, except if you know what settings you are editing, the defaults are pretty much good to go!

(I hope this solves your problem)
Of course If even in the Disk Management the disk is not shown then you got a problem, try plugging the hdd into other Sata ports as well.
Tell us if anything new happen.
 
Reactions: Matty_wxyz
Dec 21, 2021
7
0
10
0
You probably haven't formatted the HDD. When you buy any new Storage it's unformatted so the Windows cannot identify it as to what it is.
Go into Start (down in the windows icon) search for <Disk Management>
All your Storages should be on Blue color except for your new one, the unformatted ones are in black color, right click on it and click on format, follow the steps and just press next to pretty much anything that comes, except if you know what settings you are editing, the defaults are pretty much good to go!

(I hope this solves your problem)
Of course If even in the Disk Management the disk is not shown then you got a problem, try plugging the hdd into other Sata ports as well.
Tell us if anything new happen.
Unfortunately, I tried this already
 
Dec 21, 2021
7
0
10
0
Please list full specs of your system.
Do you have any M.2 drives in there. Those may disable some sata ports.
To answer your question about the m.2's... I do have 2 of them in there. Each 1 TB

Full Specs:

Board - MSI MPG z390 Gaming Pro Carbon
Power Supply - Rosewill 750 W Modular Bronze
CPU - Intel i7 9700k
CPU Fan - GAMDIAS CHOINE M1A 240R 240mm RGB All-In-One CPU Liquid Cooler
Graphics Card - MSI GTX 1080 Armor OC
Storage - Intel 660p Series M.2 2280 1TB PCIe NVMe + Team Group MS30 M.2 2280 1TB SATA III
Memory - 4 X 8 GB DDR4 Teamgroup
System Fans - Case provided rosewill fans

Drive I'm trying to connect:

Seagate BarraCuda ST2000DM008 2TB 7200 RPM
 

ASK THE COMMUNITY

TRENDING THREADS