Question Hdd won’t detect on pc just built

Mar 6, 2021
3
0
10
0
Recently built my first pc specs
Asrock B450 hdv
Ryzen 52600 rx 560
Xpg z1 ddr4 16gb 3000mhz
Western digital 1tb
Pc booted into bio and I plugged in a usb with windows saved changes and exited and got to windows installation screen well when you choose the drive to install windows on and my hdd isn’t being detected I’ve replugged the sata cable in several times and am considering buying an ssd to fix the issue and other solutions?
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Make and model of your PSU? Which SATA port are you populating on the motherboard? Ideally you should work with SATA3_1. Out of curiosity, since you're able to get into BIOS, what BIOS version are you currently on? Where did you source the installer for Windows 10?
 
Mar 6, 2021
3
0
10
0
I have it on sata 1 or maybe 2 if I’m reading it wrong but should be one and I’m not sure how to check the version I just know it’s 8/10/2020 in the bottom right and I got it from the windows website my friend used the usb prev to boot his pc into windows so that’s how I know it works
 
Mar 6, 2021
3
0
10
0
I have it on sata 1 or maybe 2 if I’m reading it wrong but should be one and I’m not sure how to check the version I just know it’s 8/10/2020 in the bottom right and I got it from the windows website my friend used the usb prev to boot his pc into windows so that’s how I know it works
I’m willing to send pictures if need be
 

ASK THE COMMUNITY

TRENDING THREADS