Question HDMI Port only uses Intel Integrated graphics, how can I make it use Nvidia graphics card too?

Jul 11, 2019
3
0
10
0
I have a Gigabyte p37x laptop with both an Intel integrated graphics card and an Nvidia 980m graphics card. The laptop only has 1 HDMI port, and I'm trying to set up an HTC Vive to use with it, which uses the HDMI port. However, it seems that the HMDI Port is connected to the integrated graphics card, not the NVidia graphics card, as when I disable the integrated graphics card, the HDMI port stops working. Is there a way to force the HDMI port to use the NVidia graphics card instead of the integrated graphics? I can still use VR with either, but the integrated graphics card has really shitty quality that makes the VR display hard to see and use. Thanks in advance.
 

Crosslhs82x2

Notable
Aug 12, 2017
491
35
890
27
If you got nvidia geforce experience on your system.
Click on your icon tray lower right corner of your task bar.
It will show items running right click on nvidia geforce
then left click on nvidia control panel.
With control panel open click on manage 3d settings.
look above global settings and progam setting in the middle of the page.
You should see a drop down list with your intel and your nvidia listed click nvidia what card you have and then apply at the bottom right.


If you don't have nvidia geforce experience then download it then follow the above steps.
 
Jul 11, 2019
3
0
10
0
If you got nvidia geforce experience on your system.
Click on your icon tray lower right corner of your task bar.
It will show items running right click on nvidia geforce
then left click on nvidia control panel.
With control panel open click on manage 3d settings.
look above global settings and progam setting in the middle of the page.
You should see a drop down list with your intel and your nvidia listed click nvidia what card you have and then apply at the bottom right.


If you don't have nvidia geforce experience then download it then follow the above steps.
I've already tried that (extensively), it didn't work... tried changing global graphics card settings, changing individual program settings, everything. It's not that i'm having a problem running programs on the laptop's main screen with NVidia, it's that the VR, which is running through the HDMI port, is only running on the integrated graphics card instead of the NVidia card. It seems like the Nvidia card isn't even connected to the HDMI port, because disabling the integrated graphics card makes the HDMI port not work at all.
 

ASK THE COMMUNITY

TRENDING THREADS