Jul 19, 2022
Hello everyone,

I really need some help. I have only had my new computer for less than 12 months and recently i started experiencing:

- Blue screen of death

- Random restarting of PC

After following alot of different fixes online, including both, file saved and complete reformatting. The random restarting is still occuring.

Today's errors in event viewer shows the latest ones show as:

The computer has rebooted from a bugcheck. The bugcheck was: 0x00000116 or The computer has rebooted from a bugcheck. The bugcheck was: 0x0000007f

And lots of event log warnings for Event ID: 10016.

This is starting to drive me a bit crazy as I bought my expensive computer for my home business and for the past month this has been occurring and I'm finding it very hard to do any work and i'm suffering because of it. If I can get some help solving that would be very great. I've gone through everything and completed most of the tests. Expect Bios update and overnight memchk. I have also already tried replacing my memory sticks, changing slots and switching out my power supply cable - as you can see, I'm desperate.

I've continued to have issues. This week, my computer would turn on and light up, but nothing would display on the monitors. I had a technician come out, and they took it to their shop to investigate. After some mucking around they tested the GPU in another PC and it worked fine. From there they determined that it was my Corsair 850X power supply that wasn't getting enough power/failing which was causing the random resets due to GPU not having enough power.

I've just taken my PC home with the new power supply and can connect to both displays, plugged everything back in and shortly thereafter, the random restarts twice with no BSOD with bugcheck was: 0x00000116". Then two days nothing then, BSOD for kernel error. I did notice that twice it did this while on zoom/teams calls. So I disconnected my Logitech steam cam from usb-c port and plugged in my phone and no errors for several hours. plugged the streamcam back in and used it and within 30mins a crash. I bought a usb-c to usb-A to change the ports to test, but kernal error happened again this morning. I'm currently leaving the Logitech stream cam unplugged completely to see if it's someone causing the issue from hardware even when not in use.

I'm happy to provide the dump or logs if useful. Can someone please help me?
i am looking at the memory dump from july 19
it was a double fault which means the system hit a problem and transferred control to a fault handler which also hit a problem.

generally, you see this with over heated systems.
It looks like your network adapter disconnected and would not reconnect. problem is the adapter is rt640x64.sys and is directly connected to your pci bus. looked like the device was running for hours then went to a unknown state (kicked off the pci bus)

this should be a low level problem maybe the bios update and chipset update might fix it. Note: AMD makes you remove the old chipset drivers before you add the new chipset drivers or you have strange issues.

file: amdppm.sys (amd primary processor module)
amdppm internal log shows no errors.

some problem with a locked thread involving

usb log complained that after 60 million messages it stopped getting traffic and put up a warning that the stream might have failed. (could just be you unplugged the device)

here is what may have happened:
you unplugged the usb-c from a graphic card
the usb driver thought the device failed and issued a reset of the device. Since the device is connected to the graphic card it reset the bus and recovered but for the network device was also reset and kicked from the bus and should have reconnected but the rootkit scanner would not release the lock until it scanned the network down traffic and the network traffic could not complete since the network driver was unloaded. And the driver could not load until the scanner gave up the lock.
this would be a bug in the scanner.

it might be prevented if you can eject the usb device before you disconnect. or use different usb-c port.
(best guess)
Last edited:
Jul 19, 2022
Hi again Johnbl,

Yes I was testing if it was related specifically to my Logitech streamcam, which I have unplugged for a few days without a crash. I plugged it back in today for some meetings and I crashed 4 times while on video calls. I've updated the memory dump file if you wouldnt mind please taking a further look with the new daily crash data. I cant be sure it's only with the webcam but that is where my guess is currently.

Memory dump new file 22-07-22: https://www.dropbox.com/s/mqkpbn1gl42xwaj/MEMORY.DMP?dl=0

I've tried a few combinations as well for the webcam such as usbc, usbc converted to A and usb3 and usb2 ports. all variations some to crash at some point. I currently have my webcam unplugged again and no crashes yet...
note: there was a failed device install that could be the cause of this bugcheck (disabled interupts)
InstancePath is "ROOT\MEDIA\0001"
the error returned was
Error code: (NTSTATUS) 0xc0000490 (3221226640) - There are no compatible drivers available for this device.

most likely requires some motherboard driver.
it was an autogenerated device.

note: looks like root\media\0002 is your camera driver
InstancePath is "ROOT\MEDIA\0002"
ServiceName is "ElgatoVirtualCamera"

root\media\0001 might be a failed install related to the camera. You might go into windows control panel find the failed device and delete the entry, then rescan hardware and see if plug and play reinstalls the device correctly.
(or it could just be a duplicate entry now installed as \root\media\0002 then pnp should not try to install it after you delete the bad entry.

was ServiceName is "iriuna0"

bugcheck was amd processor driver talking to the cpu while interrupts disabled.

most likely some problem in sleep states.
you might google amdppm!ReadIoMemRaw
to find other people with the same problem.

in the past, I have seen this with bugs in the actual cpu that are fixed by a bios patch that blocks the address.

you are using the generic microsoft driver, most people would disable it and lock down the cpu speed. I would just look to see if you just need to update the bios version. (lots of changes in bios because of hackers code released 6 months ago)
otherwise, it there is no bios update i would install amd version of the drivers (amd chipset updates directly from amd)
I expect your best fix is a bios update . https://www.asrock.com/mb/AMD/B550 Pro4/index.asp#BIOS
looks like the update is a beta bios

cpu came out Q4 2020
LogiTuneUpdater.exe was running (firmware update tool)
you should exit this tool.

8: kd> !sysinfo machineid
Machine ID Information [From Smbios 3.3, DMIVersion 0, Size=2050]
BiosMajorRelease = 5
BiosMinorRelease = 17
BiosVendor = American Megatrends International, LLC.
BiosVersion = P2.20
BiosReleaseDate = 02/24/2022
SystemManufacturer = To Be Filled By O.E.M.
SystemProductName = B550 Pro4
SystemFamily = To Be Filled By O.E.M.
SystemVersion = To Be Filled By O.E.M.
SystemSKU = To Be Filled By O.E.M.
BaseBoardManufacturer = ASRock
BaseBoardProduct = B550 Pro4
BaseBoardVersion =
8: kd> !sysinfo cpuinfo
[CPU Information]
~MHz = REG_DWORD 3693
Component Information = REG_BINARY 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
Configuration Data = REG_FULL_RESOURCE_DESCRIPTOR ff,ff,ff,ff,ff,ff,ff,ff,0,0,0,0,0,0,0,0
Identifier = REG_SZ AMD64 Family 25 Model 33 Stepping 0
ProcessorNameString = REG_SZ AMD Ryzen 9 5900X 12-Core Processor
Update Status = REG_DWORD 1
VendorIdentifier = REG_SZ AuthenticAMD
8: kd> lmvm amdppm
Browse full module list
start end module name
fffff80792200000 fffff80792244000 amdppm # (pdb symbols) C:\ProgramData\dbg\sym\amdppm.pdb\626FFFF250B91B5FF36F4DAB364F70C01\amdppm.pdb
Loaded symbol image file: amdppm.sys
Mapped memory image file: C:\ProgramData\dbg\sym\amdppm.sys\3D75D48544000\amdppm.sys
Image path: \SystemRoot\System32\drivers\amdppm.sys
Image name: amdppm.sys
Browse all global symbols functions data
Image was built with /Brepro flag.
Timestamp: 3D75D485 (This is a reproducible build file hash, not a timestamp)
CheckSum: 0003EB61
ImageSize: 00044000
Translations: 0000.04b0 0000.04e4 0409.04b0 0409.04e4
Information from resource tables:
Last edited:
Jul 19, 2022
Hi everyone,

Just wanted to provide a final update. Turns out it was probably an initial failed power supply and then i've lastly swapped out the cpu after having run out of options (including swapping the motherboard and ram) and zero crashes for this week.

Thanks for everyone's help in trying to determine the issue from the dumps and trouble fixes.