Question Help! Newly built pc is randomly restarting

Jul 24, 2020
6
1
15
0
Sorry I didn't know which thread to put this in


So i built my first pc about a month or two ago and sometimes it would randomly restart!

It mainly restarts when loading up a game but it does restart when I'm watching YouTube or just TV but I've looked around and can't seem to find any thing

I've check the temps for the graphics card and the cpu they're all fine but i don't know what could be causing the issue

The weirdest thing is it only happens sometimes I can load up a game and then play it for hours on end with no issue but if I decide to go off the Go back on later it (close down the app) it will just go black screen and restart no fans in pc will turn off they all stay on just the pc will restart I'm stuck can't find any thing, the parts for the pc are new apart from the ram which I took out of my older pc with I only bought last November but I decided to upgrade

Another weird thing is if I open up another app such as Google first, the game can loads up (sometimes) but after a restart I could like 5-10 minutes without opening an app and it would just restart again!

I've also checked for loose cables which there isnt any

I'm very confused and looked around as much as I can couldn't find anything to help

MOBO - MSI gaming plus max
CPU - Ryzen 5 3600
GPU - Vfx RXT 590 'Fatboy'
PSU - EVGA 700w br
RAM - CORSAIR VENGENCE x2 8gb

Any help will be much appreciated
 
Sorry I didn't know which thread to put this in


So i built my first pc about a month or two ago and sometimes it would randomly restart!

It mainly restarts when loading up a game but it does restart when I'm watching YouTube or just TV but I've looked around and can't seem to find any thing

I've check the temps for the graphics card and the cpu they're all fine but i don't know what could be causing the issue

The weirdest thing is it only happens sometimes I can load up a game and then play it for hours on end with no issue but if I decide to go off the Go back on later it (close down the app) it will just go black screen and restart no fans in pc will turn off they all stay on just the pc will restart I'm stuck can't find any thing, the parts for the pc are new apart from the ram which I took out of my older pc with I only bought last November but I decided to upgrade

Another weird thing is if I open up another app such as Google first, the game can loads up (sometimes) but after a restart I could like 5-10 minutes without opening an app and it would just restart again!

I've also checked for loose cables which there isnt any

I'm very confused and looked around as much as I can couldn't find anything to help

MOBO - MSI gaming plus max
CPU - Ryzen 5 3600
GPU - Vfx RXT 590 'Fatboy'
PSU - EVGA 700w br
RAM - CORSAIR VENGENCE x2 8gb

Any help will be much appreciated
That is strange behaviour - based on your descriptions it does sound like it's graphics card related.

First question, what graphics drivers are you using? I am assuming you downloaded the latest drivers directly from AMD for the gpu?

It might be worth trying to do a full reinstall of the drivers, the best way to do this is run the 'Display Driver Uninstaller tool' (DDU for short), link here: https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

Then download and install the latest radeon drivers from AMD.

If the machine still reboots after that, it's probably worth taking a look at the Windows Event Viewer (just type 'Event Viewer' into the Windows 10 search box) and look to see if there are any entries in the 'critical' section. This might give you a bit of insight what the cause of the issue is.

The other cause of this kind of issue can be memory instability - what speed ram kit do you have, also what motherboard do you have exactly as you don't list the chipset, I am assuming it's a B450 series motherboard? If it's an older board (e.g. a B350 series board) then you might have problems running memory at the rated speed as typically B350 / X370 boards don't like memory above ~ 2933 mhz, even with a newer Ryzen cpu.
 
Reactions: kurdtnz
Jul 20, 2020
9
0
10
0
Duuude i have the problem as yours, did your steam or discord also crashes tho ?
edit : I also using the same cpu as yours and ram (2666)
 
Jul 24, 2020
6
1
15
0
That is strange behaviour - based on your descriptions it does sound like it's graphics card related.

First question, what graphics drivers are you using? I am assuming you downloaded the latest drivers directly from AMD for the gpu?

It might be worth trying to do a full reinstall of the drivers, the best way to do this is run the 'Display Driver Uninstaller tool' (DDU for short), link here: https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

Then download and install the latest radeon drivers from AMD.

If the machine still reboots after that, it's probably worth taking a look at the Windows Event Viewer (just type 'Event Viewer' into the Windows 10 search box) and look to see if there are any entries in the 'critical' section. This might give you a bit of insight what the cause of the issue is.

The other cause of this kind of issue can be memory instability - what speed ram kit do you have, also what motherboard do you have exactly as you don't list the chipset, I am assuming it's a B450 series motherboard? If it's an older board (e.g. a B350 series board) then you might have problems running memory at the rated speed as typically B350 / X370 boards don't like memory above ~ 2933 mhz, even with a newer Ryzen cpu.


Thanks for the reply I reinstalled the drivers and thought was everything was fine but it just restarted again and another issue has appeared where the the pc would reboot but now it stays black screen until I turn the pc off then on again wasn't playing a game or anything I was just sitting watching YouTube it's weird

Yeah sorry I knew I forgot some thing it's a B450 Gaming plus Max

The ram is a ddr4 I think what you meant

The event viewer says the only critical thing is Kernel Power - 41 which I read somewhere that it only appears when the pc is closed uncleanly
 
Jul 24, 2020
6
1
15
0
Duuude i have the problem as yours, did your steam or discord also crashes tho ?
edit : I also using the same cpu as yours and ram (2666)
Nothing crashes it just goes black and the there's no source to the pc but everyrhing is still on such as the fans and rgb lights in the pc it's really bugging me especially that I've got work and it's just randomly restarts
 

R_K

Honorable
Jul 22, 2014
62
3
10,545
1
Nothing crashes it just goes black and the there's no source to the pc but everyrhing is still on such as the fans and rgb lights in the pc it's really bugging me especially that I've got work and it's just randomly restarts
I had similar issue with my pc too which is Ryzen 2600 with Msi B450 Tomahawk, and only 3 months old.
After testing each components with different Pc, finally it turned out the Motherboard was the issue.

So, I would suggest you to check each component mainly PSU, RAM, GPU on a different PC, if those turns out to be running ok then it's the Motherboard. Msi motherboards tends to be like this.
 
Reactions: cdrkf
I had similar issue with my pc too which is Ryzen 2600 with Msi B450 Tomahawk, and only 3 months old.
After testing each components with different Pc, finally it turned out the Motherboard was the issue.

So, I would suggest you to check each component mainly PSU, RAM, GPU on a different PC, if those turns out to be running ok then it's the Motherboard. Msi motherboards tends to be like this.
The above is good advice... if it does appear to be the motherboard It might be worth trying to do a Bios update and see if that helps - it could also be settings related, so it might be worth trying going into the bios and using the 'load defaults' option (not sure what the exact wording) and see if that improves things.
 
Jul 24, 2020
6
1
15
0
I had similar issue with my pc too which is Ryzen 2600 with Msi B450 Tomahawk, and only 3 months old.
After testing each components with different Pc, finally it turned out the Motherboard was the issue.

So, I would suggest you to check each component mainly PSU, RAM, GPU on a different PC, if those turns out to be running ok then it's the Motherboard. Msi motherboards tends to be like this.
Okay thank you the only issue is that I don't have another pc around to test on :/
 
Jul 24, 2020
6
1
15
0
The above is good advice... if it does appear to be the motherboard It might be worth trying to do a Bios update and see if that helps - it could also be settings related, so it might be worth trying going into the bios and using the 'load defaults' option (not sure what the exact wording) and see if that improves things.
I did a Bois update an thought it was fine for the last day or so but then this morning it did it again I'll try the default settings and see if that helps :)
 
Reactions: cdrkf
Jul 24, 2020
6
1
15
0
Just an update I reset the Bois to default and it wouldn't allow me to get back onto the pc it would just restart so I look around and saw someone say re seat the ram I did they and managed to get back on

I am currently scanning for malware and viruses using bull guard just on case.

Is there any information that I could give you that might help with the investigation?

I did see in the Bois that my ram is at 2133mhz when in the back of the ram sticks it says the ram is 3000mhz could that be anything to do with it I'm not sure?

Also I'm not great with pc some stuff is confusing to me but some stuff I can understand I have a couple of friends that know a bit about pcs and one told me that it could be a windows 10 thing wondering if resetting windows might help?

Although I am a little worried that I would lose some files of important work especially that I have a deadline around the corner but I think I can find a USB to back them up

I just wanna say to everyone that's help I really appreciate the help it's stressful trying to figure this out and you guys/girls have been a massive help <3
 
Jul 20, 2020
9
0
10
0
Just an update I reset the Bois to default and it wouldn't allow me to get back onto the pc it would just restart so I look around and saw someone say re seat the ram I did they and managed to get back on

I am currently scanning for malware and viruses using bull guard just on case.

Is there any information that I could give you that might help with the investigation?

I did see in the Bois that my ram is at 2133mhz when in the back of the ram sticks it says the ram is 3000mhz could that be anything to do with it I'm not sure?

Also I'm not great with pc some stuff is confusing to me but some stuff I can understand I have a couple of friends that know a bit about pcs and one told me that it could be a windows 10 thing wondering if resetting windows might help?

Although I am a little worried that I would lose some files of important work especially that I have a deadline around the corner but I think I can find a USB to back them up

I just wanna say to everyone that's help I really appreciate the help it's stressful trying to figure this out and you guys/girls have been a massive help <3
Well just like what the guy above said, tried your component in different pc, did it works or not. But if you don't have another parts to test that out, just bring your pc to repair center.
 

ASK THE COMMUNITY

TRENDING THREADS