Question Help!! No display output after upgrading GPU

RajTheGeek

Commendable
Aug 12, 2020
67
0
1,530
0
So I just upgraded from GTX 1060 to Asus RTX 2060 12 GB. As soon as I did it I played game for few mins. Everything was fine because I had enabled Vsync so that was capping at 60 fps. As soon as I disabled it to check how further it goes. After 5 mins game got crashed, closed and system got hanged. Then I tried to boot it up again but no display port. Both gpu fans spinning. Then I put my older card and same issue.

Afterwards, I reset the CMOS jumper to reset BIOS putting screw driver for 10 seconds and removed the battery for 2-5 mins. I also removed my one RAM slot(2 *GB sticks) and then boot it up again and it worked. So here's what happened:
  1. after that, when I logged in first time after few mins blue screen error came up.
  2. I tried 2nd time to boot up and everything seemed fine.
  3. Then I installed my 2nd RAM stick and seemed everything is working
  4. Then I changed it to my newer GPU and played it for a while. So far it seems to be working. I even played under heavy gpu load for a while(99% usage, 80C temp, 180W) and it seemed stable
NOW, I'm really worried about what I should do. Can anyone tell me what caused that? I don't want my PC to crash again. Here's my specs:

Ryzen 3 3100
MSI b450 Tomahawk max
Asus dual RTX 2060
Corsair CX 550W
No overclocking except enabling XMP
 

RajTheGeek

Commendable
Aug 12, 2020
67
0
1,530
0
Your power supply is insufficient, you need at least 650w, i suggest going for a 750w Gold or platinum if you can afford it.
I have checked my psu is sufficient. You can check my other threads. considering my pc specs and my rtx 2060's specs 550w will provide enough headroom at least for now
 

RajTheGeek

Commendable
Aug 12, 2020
67
0
1,530
0
It's not sufficient, it's 550w of mediocre quality.

But seeing as you know better, I'll let you get on with working out what your issue is.
gpu=185W max
cpu=65W max
other components=100W
Total=350W. That's approx maximum how much my PC should draw when I'm playing. Also for safety I have put the gpu on silent mode via gpu tweak so its boost clock is 1650 instead of 1680 and power draw is also max around 165 to 170W max. That's the least I should expect any half decent 550W psu to handle. But let me know if I'm wrong about this.
 

ASK THE COMMUNITY

TRENDING THREADS