Help with radeon 7870

davschall

Honorable
Nov 19, 2012
123
0
10,710
7
Hey everyone so Im having issues with my His iceq 7870 it was working fine until a few days ago when i was playing company of heroes it just crashed, and would not let me access anything without a restart. Now it happens with every game i play almost, and in games that it doesnt crash I get artifacts and blinking screen (a huge nuisance). The card isn't overheating the highest it goes is 46-54 (thanks to the handy dandy his iceq cooler).

I have its slightly oced at 1150 and 1275, Im running the 12.11 beta drivers (newest update available im not sure which) ive searched and searched, its hard for me to understand, so i figured id ask the experts. Am i looking at a bad card? That would be incredibly irritating because I sent in the mir because it seemed to be working fine. Has anyone heard of these problems? Have any solutions? ill try a few more things in the morning but for right now i need to go to bed lol.
System specs His iceq hd7870
asus m4a785td-v evo
Amd Phenom II x4 BE @ 3.8
gskill ripjaws 4x2
wd 500 caviar black
ocz Fatal1ty 750w
Any help would be aprreciated im pretty upset cause this is my first build and I really just wanted it to work without issues that were beyond my abilities. Thanks everyone and goodnight!
 

davschall

Honorable
Nov 19, 2012
123
0
10,710
7
Yea I do know that, the only thing is I bought it from newegg and its iron egg, so it would have been much faster to just exchange it and upgrade to like a 7970 now that i have the cash. Idk if his will let me pay the difference to get a 7970 or even 7950. Im gonna try reseting to stock clocks i suppose but it really doesnt make a whole lot of sense why it would be acting up like this.
 

davschall

Honorable
Nov 19, 2012
123
0
10,710
7
Alright ill try it are you thinking its a software issue? Cause it seems everyone having problems with the 7870 think its hardware related. Also could it possibly be my mobo? The thing is like 3 years old lol.
 

Junpaku

Honorable
Nov 27, 2012
13
0
10,510
0
It may be a software issue, not sure about the mobo compatibility D:
I also have a 7870 on a gab75md3h, but I've only had it for two days with 12.08, so far no problems.
 

davschall

Honorable
Nov 19, 2012
123
0
10,710
7
Well I down clocked it and now the games dont crash so it could have been my oc was unstable which makes no sense, it was hardly an oc, btrange thing is coh is unplayable now (started before I down clocked) so much lag its nsane wheras far cry 3 runs perfectly on ultra with 2x msaa
 

Similar threads


ASK THE COMMUNITY