[SOLVED] High Idle Memory Usage

Feb 11, 2021
3
0
10
I've noticed my idling RAM usage is somewhere between 60-80%, is this something I should be concerned about or is my system just using a lot of my memory as a cache? It says only 3gb is being used as cache and the other 12gb are in use, but no where in my resource monitor does it show what's using that much RAM. All of my processes maybe add up to like 1.5-2gb memory. I figured the resource monitor might not be accurate, but wanted to be sure.

Windows and drivers are up to date. I did upgrade to Windows 10 Education recently so I can use virtualization.

View: https://i.imgur.com/b50gGy9.png


I apologize for opening a new thread on this as there are multiple with the same issue, but none that have been resolved as of yet.

RAM is 2x8 G.Skill Ripjaw 3200
 
Could you post the system specs.
It could be a be a memory leak since the Task Manager does not appear to list all that RAM in use.

Try updating the network and audio drivers.
Also it could be cause by an app running on the background (Spotify, Windows store, ).
Configure apps not to start automatically or run in the background when not in use.
 
  • Like
Reactions: Krotow
Feb 11, 2021
3
0
10
I did try a clean boot and it lowered the usage from 80-70.

Currently using a GTX 1060 6GB
AMD Ryzen 7 2700 8 core 3.2ghz
RAM is 2x8 G.Skill Ripjaw 3200
MOBO is B450 AORUS PRO WIFI

Thank you for the quick replies. I will try glary utilities
 
Feb 11, 2021
3
0
10
Used Glary utilities, fixed some registry problems and shortcut issues that CCleaner didn't, so I imagine one or the other is just 'fixing' issues to make it look like it's doing something. Is there anything else I should do with Glary?