Question How can I fix system interrupts?

Apr 22, 2019
22
1
15
0
Hello!I am using Windows 10 pro and when I open task manager the cpu usage is 40-50% and after 2 seconds a thing called system interrupts appears and it uses almost all cpu usage.Can I fix this somehow?I restarted my pc and I tried some solutions I found on internet but didn't help.Any advice?
 
Apr 22, 2019
22
1
15
0
I have a ssd in my laptop by default.It's not 50% usage everytime.It's like 40-70 and sometimes even 100 and after 3 seconds it drops very much. Specs:Ryzen 7 3750H,GeForce GTX 1660 Ti with 8gb and 8gb ram.
 

Colif

Win 10 Master
Moderator
okay then, we go long way

can you download and run driverview - all it does is shows what drivers are running
http://www.nirsoft.net/utils/driverview.html
when you open it, go to View tab and set it to hide all Microsoft drivers or list will be several pages long

take a screenshot showing file name and the date columns (creation date is one of them). Then upload it to an image sharing website and show a link here

I will see what you are running and find newer versions.

Can you search for system information in windows search
open the app
under Processor heading it should say what Bios version you are on, can you give me that as well?
 

britechguy

Commendable
Jul 2, 2019
1,480
238
1,340
140
Have you tried simply checking to see if this behavior persists?

There are many processes that, upon Windows startup, sometimes can and do consume a lot of CPU cycles, but that does not persist.

If you've ever had a machine shut down for a period of time, the Antimalware Service will eat up scads of CPU until its initial scanning is done, but it goes away.

CPU spikes for anything are perfectly normal, and often at known points in time. If they persist constantly then you have a problem.
 

Colif

Win 10 Master
Moderator
There are newer Lan drivers, you have version 9, there is version 10 on website
you appear to have the latest with everything else, even newer in some cases.

I assumed when I asked is it 50% all the time he meant even after startup, I realise I should have checked.

you have newest bios
 

ASK THE COMMUNITY

TRENDING THREADS