Question I am unable to enable XMP 2.0 without Windows having a breakdown... Help me

Feb 1, 2020
25
1
45
2
PC was working great! RAM overclocked to 3000MHz from 2666MHz, XMP enabled. Then I decided to upgrade my 2200G to a ryzen 5 3600... oh no. First boot was perfect, windows was fine. Ran a little test and remembered my ram is at 2133MHz so went to the BIOS to fix it. Enabled XMP and overclocked to 3000MHz. Tried to enter windows but it just gave me a black screen. Reset CMOS. Windows was fine, XMP was disabled. Went to BIOS, enabled XMP, and Windows refused to start, kept on saying it was 'fixing it', but nothing happened until I turned it off and on.

Overall I'm left with ram going 2133MHz. How can this be solved?

Specs:

Ryzen 5 3600
RX570
A320-HDV
Corsair 550W
16GB RGB Corsair 2666MHZ base
 
First you need to realize that the memory controller is on the CPU itself so changing the CPU changes the memory controller and not every memory controller can handle the same speeds with the same clocks.

Be sure when you enable the XMP profile it is not setting the ram command rate to T1, have it set to T2 this will help with the higher speed settings.

XMP is actually an Intel technology and not guaranteed to work with AMD CPU's. Your issues are stemming from the CPU's memory controller not being able to run the tighter timings or potentially the memory controllers voltage is slightly to low to handle the extra strain of the faster timings.

I suggest that you set the speed and timings to what is on the sticker on the side of the ram, 2666MHz and you may have to go to manufactures page for the timings. If the ram is 2666 MHz then 3000 MHz is an overclock and that is not a guarantee that it will work with all CPU's.
 
Last edited:
Feb 1, 2020
25
1
45
2
First you need to realize that the memory controller is on the CPU itself so changing the CPU changes the memory controller and not every memory controller can handle the same speeds with the same clocks.

Be sure when you enable the XMP profile it is not setting the ram to T1, have it set to T2 this will help with the higher speed settings.

XMP is actually an Intel technology and not guaranteed to work with AMD CPU's. Your issues are stemming from the CPU's memory controller not being able to run the tighter timings or potentially the memory controllers voltage is slightly to low to handle the extra strain of the faster timings.

I suggest that you set the speed and timings to what is on the sticker on the side of the ram, 2666MHz and you may have to go to manufactures page for the timings. If the ram is 2666 MHz then 3000 MHz is an overclock and that is not a guarantee that it will work with all CPU's.
do you recommend I set the speed to 2666MHz but leave the XMP bit to auto?
 
I recommend manually setting the speed to 2666 and the timings to what the manufacture states your RAM runs at. there are 3 main timings, some times printed on the sticker on the side of the ram but if not then go to the manufactures web site and look up your ram. Don't mess with the XMP settings as they are meant to put the ram in to performance settings that not all CPU's can handle. set the ram the way the manufacturer recommends.

main timings
Cas
Ras to Cas
Ras pre time
Ras act time = the sum of the 3 above it so 9-10-9 would be 28 for Ras act time as an example.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS