Question I'm having issues with the GPU clock speed on Dell Inspiron 5502 with a Geforce MX330 ?

Sep 16, 2021
11
0
10
0
so the mx330 base clock is 1531mhz but when ever I game I get below 1kmhz i tried locking the frequency with MSI afterburner . it stays locked for a few seconds and then again dips back to below 1k MHZ which gives low fps and alot of stutters because of this . i need help!
 
Sep 16, 2021
11
0
10
0
A points to go over:
  • Make sure the laptop is plugged in and/or the proper adapter is being used
  • Make sure the power settings aren't set to save power
  • Check to see if the temperatures are not floating around 90C or higher
while gaming the temp is around 67-70 degree c and its on max performance with the power adapter connected
 
Sep 16, 2021
11
0
10
0
this is after playing subnautica at high settings the mhz was stuck at 139 for most of the time and went above 1k mhz for breif moments
 

uWebb429

Notable
May 22, 2020
313
109
990
40
Some Dell laptops are setting the Nvidia GPU throttling temperature ridiculously low. Run GPU-Z and find out what this temperature is set to. Instead of the typical 94°C that Nvidia recommends, Dell is using 74°C.

Good luck gaming if that is the case. The Nvidia GPU is unusable if the throttling temperature has been set to 74°C.
 
The second screenshot implies nothing was going on. 😟

But yeah, if it's hitting a temperature performance limit, then it may be aggressively throttling.

Otherwise you can try the following to make sure the drivers are fine:
 
Sep 16, 2021
11
0
10
0
The second screenshot implies nothing was going on. 😟

But yeah, if it's hitting a temperature performance limit, then it may be aggressively throttling.

Otherwise you can try the following to make sure the drivers are fine:
ty mate I really appreciate your time and effort I really do hope this works I'll keep you updated .😃
 
Sep 16, 2021
11
0
10
0
You did not drop the GPU throttling temperature but Dell might have with a recent update. Have you checked with GPU-Z yet? This is a common issue in many different Dell laptops.
i reinstalled drivers it seems to be working fine and im at base clock while playing valorant , forza horizon 4 and dell's gpu benchmark
 

ASK THE COMMUNITY

TRENDING THREADS