Incredibly (5 minutes or longer!) slow SSD from the start




I purchased a new Intel 520 series 120 GB SSD for my second pc with a Asus Striker II Extreme motherboard but from the very start it has been incredibly slow and odd.

It can randomly freeze on the Windows splash screen or hang there for 5 minutes before it goes to the password screen, it also has a habit of permanently freezing there. In the slightest chance that I do get to log in it will freeze for 30 seconds constantly when trying to open applications.

I've tried three attempts at using the data migration tool you get to transfer data from a HDD (Which still works fine) to your SSD. Aswelll as two fresh Windows 7 installs but none of it really changed a thing.

I've also tried the obvious things like changing SATA cable etc.

I'm kinda getting the feeling the SSD was just malfunctioning before I even got it, but I'm really not that good at hardware.

Help would be much appreciated!


May 31, 2012
Do you have the latest firmware? If not download the intel ssd toolbox that should fix your problems.


Jul 12, 2012
Did you disconnect your HDD while testing?
Did you set to AHCI in BIOS?
Which controller was used for connection, Nvidia or JMicron?


Thanks for your help thus far guys.

I tried the Intel SSD Toolbox, unfortunately there is no new firmware for the 520 series.

When I tried to run a diagnostic it said "The Intel SSD Toolbox cannot communicate with the selected Intel SSD. Considering changing to another storage driver compatible with your system and try the tool again."

This led me to check out the SSD in Device Manager, which is when I found out that When I go to Details -> Hardware Ids the controller actually recognizes the SSD as a SCSI.

This is when I found out I didn't have the latest JMicron drivers, which I updated but there was no improvement
(Could it be that i need the latest drivers BEFORE installing W7 on the SSD?)

Also, whenever my SSD freezes it seems to spike up my CPU usage to a full 100%.

And for the questions mad-max79 asked:

I did disconnect my HDD.
I tried setting it to AHCI but it made no improvement.
The controller used is JMicron, though as I said I updated that driver later and am not sure if that is of any influence.



Hi guys,

I managed to fix this issue by simply uninstalling and reinstalling every driver for every (3 nvidia, 1 jmicron) sata controller while running Windows on my HDD.

I then copied everything to the SSD using the data migration tool.

Kinda weird, considering there were also problems with the CPU Usage freezing to 100% but whatever, it's fixed now!

Thanks again for your help, all I'd like to ask of you now is how to select a best answer and close the thread as Solved since there seems to be a system for that, but I don't know where to select it. :)

Similar threads