Is my CPU fried? Core i5 7600k new build on ASUS rog hero maximus ix

chiliking

Prominent
May 7, 2017
11
0
520
1
Hi,

So, humbling myself first.. This is my first Intel build and it is very possible that I installed my CPU backwards and forced the clasp closed the first time I installed this CPU.

I've tried 2 boards Asus Prime z270-ar and now this one Asus ROG Hero Maximus IX
2 different power supplies, EVGA 850 G2 and now: Corsair rm850-x
2 different sets of RAM (first was not in QVL. This is now QVL certified, Corsiar vegenge lpx ddr4 3000mhz

The Q-Code on the board gets 00.
Since this is a new board, no bent pins and neither was last one. I don't think... at least the return guy didn't notice any.
I have reset the CPU a couple times.

See dark spot on bottom left... Is that a damaged part of the chip?
I can maybe clean it with alcohol next time i get to cvs and pick some up.
 

fortking

Reputable
Aug 11, 2015
53
1
4,660
5
I would have thought that it was the mobo, but you said you replaced it. If you have a really cheap cpu with thr same socket, test that. Your cpu is probably dead though.
 

fortking

Reputable
Aug 11, 2015
53
1
4,660
5
I would have thought that it was the mobo, but you said you replaced it. If you have a really cheap cpu with thr same socket, test that. Your cpu is probably dead though.
 

fortking

Reputable
Aug 11, 2015
53
1
4,660
5
I would have thought that it was the mobo, but you said you replaced it. If you have a really cheap cpu with thr same socket, test that. Your cpu is probably dead though.
 

chiliking

Prominent
May 7, 2017
11
0
520
1
As a closure to this issue. My CPU was dead. I must admit I have carpet in my room where I was setting up this machine. Maybe a spark hit it. Not sure...

Anyways, what really upset me and confused me is that there was no fault on the board stating CPU error. The Asus ROG has fault codes and cpu error light. Nope... I exchanged the CPU with the same one in box, installed and it powered on.... So.... for future users, if there is no post and all of the hardware is NEW, you might want to check your CPU.
 

ASK THE COMMUNITY

TRENDING THREADS