Question Is this a power supply issue?

zerobert

Reputable
Nov 23, 2016
3
0
4,510
0
Mobo: Asus M5A99FX Pro R2.0
CPU: AMD FX8350
RAM: Corsair Vengeance DDR3 1600mhz CL9 (4GBx2)
GPU: Gigabyte R7 250C-1GI
HDD: WD 1TB 3.5 inch internal HD
PSU: Corsair Builder series CXM 430W


Hi all, I was clearing out my pc of dust today and when I went to turn it back on I had some issues.

First the GPU wasn't turning on - oh no! but then I realised I'd forgot to plug back in a cable (next to the CPU) which was labelled EPU on the motherboard. This cable went from the motherboard into the PSU.

Anyway plugging that back in fixed the GPU, but now the MemOK! LED and DRAM LED both flash and the PC wont boot. I have tried holding down the MemOK! button as suggested on another website to fix this, but it didn't work

So to clarify, either this cable is in and the GPU works but the RAM doesn't, or this cable is unplugged and the RAM works but the GPU doesn't.

It was all working fine before I opened it up but I'd had some power supply problems in the past so I thought that might be the issue?

Thanks for any help you can give!

Edit: So it started working again but I'm still not confident in it to work reliably. Would this issue be related to the power supply?
 
Last edited:
EPU is an energy-processing software utility that provides several power-saving modes. Their is no such thing as "EPU connector" or "EPU cable".

The printing EPU on the motherboard refers to the EPU chip to the right of the printing on the PCB (Printed Circuit Board).
 
Reactions: zerobert

ASK THE COMMUNITY

TRENDING THREADS