Issues with my current computer rig.

Mitsurux

Honorable
Dec 19, 2012
8
0
10,510
I have upgraded my PC several times over the past 2 years and am noticing games running very poorly that should be able to run on max without a problem. I have a Sapphire 7950/i5 2500k/Corsair 620W(which im starting to wonder if this could be the problem?)/8 gigs of ripjaw Memory/120gig SSD and 500gig HD/ASUS P8Z68-V PRO/GEN3 motherboard/avermedia Capture Card. If there is anything that I missed that would help please let me know. Thanks in advance
 

kitsunestarwind

Distinguished
Dec 24, 2011
837
0
19,160
your specs are pretty solid and nothing there looks that old
Have you updated all your drivers and windows, scanned for viruses and generally cleaned up your software recently at all

Have you checked all your temps to make sure nothing is overheating
checked and cleaned dust from your heat sinks on CPU and GPU
 
start with the mb make sure it has the newest bios. use cpu-z asnd gpu-z. make sure your ram running at it rated speed. you may have to turn on xmp profile in the bios. with the video card make sure running at 16@ speed. I would check the bios make sure things that are not used like 3 party sata ports are turned off. you may with the video capture card be running out of pci lanes.
 

Mitsurux

Honorable
Dec 19, 2012
8
0
10,510
The PSU is the oldest piece that I havnt replaced since 2010 and i've updated my drivers/windows/anti virus. Tried about 3 different video drivers after doing driver sweep to make sure it was a clean install and my GPU is in the correct PCIe slot for using a single GPU and not crossfire. I'm not sure I updated my bios tho and my ram is about a year old. Windows detects 8 gigs of ram but i've never tested that to see if its working perfectly. My temps are all good. Under full load my CPU is at 55 and thats running prime95 and my GPU barely goes over 60 while playing games like Far cry 3 but i still get major lag in games that my rig shouldn't.