[SOLVED] Keyboard and mouse turns on PC from sleep immediately

OhMiBod

Reputable
Jan 8, 2017
25
0
4,530
0
I used a y cable to wired my keyboard and mouse into a single USB. It sounds complicated but the mouse and keyboard works while sharing 1 USB port

I have a USB c cord that plugs from my PC to keyboard. I decided to buy multiple extenders and converters.

1. Plugged the USB c end into a USB c to USB A converter(USB 2.0)

2 . Plugged the USB A tip for the converter into a USB A female with another USB A female end(3.0)

3. I then plugged a Y Cable(USB 2.0)with USB A male on the end(white color USB port) into the USB female. The USB Y Cale has 2 additional USB A female plugs

4. Lastly, I plugged the mouse and keyboard cable directly into the 2 USB A females on the Y Cable.

everytime I do this the mouse and keyboard always has to register itself even when the PC wakes up from sleep.

The PC would go to sleep, then wake up a second later. I even adjusted power settings and sleep settings and turned hibernation on. I made sure that the mouse and keyboard doesn't wake the PC in device manager .

not sure what the issue is. When I unplug the mouse and keyboard then the PC goes to sleep so I think it's the cables that I set up.

if I don't use the extenders and plug the peripherals separately into their own USB ports or use the 2.4ghz dongle, the PC sleeps ok.

i even tried to change the USB c cable to a micro USB and use a micro USB converter instead but no luck.

can someone help me?

coould it be the y cable? I read on an Amazon review somewhere in a product review where a customer said a y Cable he bought with a USB A with white color that has a USB A with blue attached together as y cable. He said his PC was not shutting off when he plugged it into his keyboard or mouse

if someone can help me please I would appreciate
 

Ferimer

Distinguished
Thanks for the help but I figured the problem out yesterday before I saw your reply. The problem was the 2.0 cable aka the y cable. It was the mouse and the y cable. When I left only the keyboard plugged into the 2.0 y cable it stayed asleep but not for the mouse.

What I did was I replaced the y cable with a USB hub dongle 3.0(luckily I had 1) the dongle hub is a male 3.0 with one 3.0 hub and two 2.0 hub.

Now almost everything is 3.0 I'm assuming the Razer wire that came with my keyboard and mouse are 3.0 too since it's a 2019 high end gaming model. The only thing left that isn't 3.0 is the USB c female converter to USB A male but since it's a type C, I'm guessing it has good high data transfer at least better than a type A 2.0.

Anyways...I plugged the mouse into the 3.0 port on the dongle hub and put the PC to sleep and voila. It didn't wake up. When I used the 2.0 hub instead it woke up. The keyboard however has to remain on the 2.0 port since there is no more 3.0 port on the hub but that's fine since the keyboard wasn't the issue.

However, I do run into a small problem. It doesn't bother me too much. While the PC is in sleep mode for too long( 30min or longer), the PC wakes up and boots from the boot logo again then resigns me in on windows. I start off where I left off though. My apps are still open. It's a rather quick process since I have an SSD. I'm still not sure why it does that. I heard that it could be driver issue
You may need to readjust your power settings that you were messing around with before. adjust that again to ensure that it just stays in sleep mode and doesn't sign out after a certain time. Windows 10 does that to act as a safety feature if your computer is considered to be a in public place (i.e work). Im glad you figured it out
 

OhMiBod

Reputable
Jan 8, 2017
25
0
4,530
0
Your computer is probably downloading and uninstalling the drivers for the mouse then the keyboard, then the mouse, then the keyboard. Endless loop
Should I uninstall the driver or reinstall? How do I stop this? It's a Razer keyboard and mouse and I have synapse app installed
 

OhMiBod

Reputable
Jan 8, 2017
25
0
4,530
0
Do you not have enough USB ports on your Motherboard/case to support them both using up one of their own?
I do but I'm running low. Also, it's inconvenient . I have way too many cords running across the room. I would like to reduce the wires . I need a solution other than using another USB slot
 

Ferimer

Distinguished
I do but I'm running low. Also, it's inconvenient . I have way too many cords running across the room. I would like to reduce the wires . I need a solution other than using another USB slot
Well you just bought a bunch of connecters and converters, all to just plug one mouse and one keyboard in one USB? wouldn't it make sense to do away with all of the extra stuff you just bought and plug them into to their own USb port?
 

OhMiBod

Reputable
Jan 8, 2017
25
0
4,530
0
Well you just bought a bunch of connecters and converters, all to just plug one mouse and one keyboard in one USB? wouldn't it make sense to do away with all of the extra stuff you just bought and plug them into to their own USb port?
They were cheap and my room is less messy. Besides I have a dog who chews wires.
 

OhMiBod

Reputable
Jan 8, 2017
25
0
4,530
0
Possibly, if you can do that then give it a try and see if that solves the problem.
Thanks for the help but I figured the problem out yesterday before I saw your reply. The problem was the 2.0 cable aka the y cable. It was the mouse and the y cable. When I left only the keyboard plugged into the 2.0 y cable it stayed asleep but not for the mouse.

What I did was I replaced the y cable with a USB hub dongle 3.0(luckily I had 1) the dongle hub is a male 3.0 with one 3.0 hub and two 2.0 hub.

Now almost everything is 3.0 I'm assuming the Razer wire that came with my keyboard and mouse are 3.0 too since it's a 2019 high end gaming model. The only thing left that isn't 3.0 is the USB c female converter to USB A male but since it's a type C, I'm guessing it has good high data transfer at least better than a type A 2.0.

Anyways...I plugged the mouse into the 3.0 port on the dongle hub and put the PC to sleep and voila. It didn't wake up. When I used the 2.0 hub instead it woke up. The keyboard however has to remain on the 2.0 port since there is no more 3.0 port on the hub but that's fine since the keyboard wasn't the issue.

However, I do run into a small problem. It doesn't bother me too much. While the PC is in sleep mode for too long( 30min or longer), the PC wakes up and boots from the boot logo again then resigns me in on windows. I start off where I left off though. My apps are still open. It's a rather quick process since I have an SSD. I'm still not sure why it does that. I heard that it could be driver issue
 
Last edited:

Ferimer

Distinguished
Thanks for the help but I figured the problem out yesterday before I saw your reply. The problem was the 2.0 cable aka the y cable. It was the mouse and the y cable. When I left only the keyboard plugged into the 2.0 y cable it stayed asleep but not for the mouse.

What I did was I replaced the y cable with a USB hub dongle 3.0(luckily I had 1) the dongle hub is a male 3.0 with one 3.0 hub and two 2.0 hub.

Now almost everything is 3.0 I'm assuming the Razer wire that came with my keyboard and mouse are 3.0 too since it's a 2019 high end gaming model. The only thing left that isn't 3.0 is the USB c female converter to USB A male but since it's a type C, I'm guessing it has good high data transfer at least better than a type A 2.0.

Anyways...I plugged the mouse into the 3.0 port on the dongle hub and put the PC to sleep and voila. It didn't wake up. When I used the 2.0 hub instead it woke up. The keyboard however has to remain on the 2.0 port since there is no more 3.0 port on the hub but that's fine since the keyboard wasn't the issue.

However, I do run into a small problem. It doesn't bother me too much. While the PC is in sleep mode for too long( 30min or longer), the PC wakes up and boots from the boot logo again then resigns me in on windows. I start off where I left off though. My apps are still open. It's a rather quick process since I have an SSD. I'm still not sure why it does that. I heard that it could be driver issue
You may need to readjust your power settings that you were messing around with before. adjust that again to ensure that it just stays in sleep mode and doesn't sign out after a certain time. Windows 10 does that to act as a safety feature if your computer is considered to be a in public place (i.e work). Im glad you figured it out
 

OhMiBod

Reputable
Jan 8, 2017
25
0
4,530
0
You may need to readjust your power settings that you were messing around with before. adjust that again to ensure that it just stays in sleep mode and doesn't sign out after a certain time. Windows 10 does that to act as a safety feature if your computer is considered to be a in public place (i.e work). Im glad you figured it out
Which option would that be under? I don't recall a settings to ensure windows 10 doesn't sign out
 

ASK THE COMMUNITY