[SOLVED] Laptop doesn't detect my headset mic

Sep 6, 2020
2
0
20
1
I got a new laptop (Acer Nitro 5) and a headset (Arctis 3). Whenever I use programs that need mic, my laptop uses the default mic. The realtek only uses the mic my laptop has and not my headset. I've tried updating realtek drivers and didn't work. I've also allowed apps to access my microphone. In discord, the program still uses default laptop mic as well as window's voice recorder. In-game voice chats also doesn't detect the mic I have.
 
Sep 6, 2020
2
0
20
1
Welcome to the forums, newcomer!

Go into Sound Manager and see what the Microphone options show for you. Make sure you're on the latest BIOS update for your laptop(if there are any pending) and then uninstall your audio drivers and reinstall them using the drivers found off of Acer's support site(for your laptop). Install the drivers in an elevated command, i.e Right click installer>Run as Administrator.
Hi, thank you Lutfij for answering. I found out that I have to set it to headset (not headphones) before using the arctis 3. It seems that 'headset' setting should be selected when prompted by realtek audio after plugging the device. Thank you for the help. Also, my BIOS is updated to its latest as well as my audio drivers. It's as simple as that, my fault. :)
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Go into Sound Manager and see what the Microphone options show for you. Make sure you're on the latest BIOS update for your laptop(if there are any pending) and then uninstall your audio drivers and reinstall them using the drivers found off of Acer's support site(for your laptop). Install the drivers in an elevated command, i.e Right click installer>Run as Administrator.
 
Sep 6, 2020
2
0
20
1
Welcome to the forums, newcomer!

Go into Sound Manager and see what the Microphone options show for you. Make sure you're on the latest BIOS update for your laptop(if there are any pending) and then uninstall your audio drivers and reinstall them using the drivers found off of Acer's support site(for your laptop). Install the drivers in an elevated command, i.e Right click installer>Run as Administrator.
Hi, thank you Lutfij for answering. I found out that I have to set it to headset (not headphones) before using the arctis 3. It seems that 'headset' setting should be selected when prompted by realtek audio after plugging the device. Thank you for the help. Also, my BIOS is updated to its latest as well as my audio drivers. It's as simple as that, my fault. :)
 

ASK THE COMMUNITY