Question Laptop GPU isnt recognised after repaste + Windows 10 update ?

shmokeh

Distinguished
Aug 13, 2012
9
0
18,510
0
The laptop in question is a HP Envy 14 1050EA with an intel i5 processor, AMD Mobility Radeon 5650 graphics card, 256gb SSD and 6gb DDR3 RAM.

I removed the previous thermal paste which was hard and cracked and replaced it with Therrmal Grizzly Kryonaut on both the CPU and GPU.
I've also installed an SSD alongside windows 10 from scratch so for all intent and purposes its a fresh install.

I've updated all my drivers according to Windows update and via a third party application - the laptop support page from HP doesn't work correctly however so I had no choice to go direct. However there are no unknown devices and I'm fairly confident everything is up to date.

In device manager it only displays Intel GPU under display and no matter what I try I cannot get it to display the AMD GPU.
I have tried installing the AMD GPU driver and software from multiple different versions, I've also tried searching within the BIOS for any options that might enable my GPU - there is however a very basic BIOS with no settings regarding the GPU. A BIOS reset didnt work either. Im open to trying to update the BIOS but as there is no product support page (it isnt working) I cannot find a compatible update file.

There is nothing I can find on the laptop to suggest that the AMD GPU even exists and I cannot for the life of me figure out why and how to fix it.

If I somehow botched the thermal paste would the laptop still function without issue (but without the gpu and using the intel inbuilt one instead) or would it warn me somehow/somewhere?

The original operating system and hardrive are no longer an option as the primary partition is corrupt somehow (I can access it via my main computer with software but it displays unallocated within disk management) . There are other partitions available with one being HP Recover but I dont know how to enable this and am unsure if it would make any difference anyway. Would reformatting the corrupt partiton and installing windows 7 enable me to use HP recovery somehow (perhaps a factory reset with the vendors drivers/programs installed would help)?

Any advice or support would be greatly appreciated, ive fixed and upgraded many laptops before and have never encountered an issue like this, very close to giving up and calling it a day!

Here is the support/drivers page for anyone interested, it just straight up glitches and doesn't display -
https://support.hp.com/gb-en/product/hp-envy-14-1000-notebook-pc-series/4173527/model/4226686
 

ASK THE COMMUNITY

TRENDING THREADS