Laptop lags in games for no reason, even having capable specs.

Status
Not open for further replies.

AbhijeetSingla

Prominent
Mar 26, 2017
15
0
510
0
I recently bought a
Lenovo Ideapad 500,
with intel core i5 6th gen,
8gb ram,
250gb 7200rpm hdd,
AMD R7 M360 4GB graphics card,
But still all of the game manage to lag in my laptop, I don't now why, even Borderlands, saints row the third, GTA V, Blur(yes!, even this game.) all lag and have a very unplayable framerate(fps)
Please help!
Also MSI Afterburner doesn't recognize my graphics driver and doesn't let me overclock my gpu.
 

ava3a13

Prominent
Apr 23, 2017
95
0
660
14
Hello friend, Are you using your GPU as source for your applications? Could you go into AMD settings and set applications to use your GPU as main source?
AMD Radeon Settings> Preferences> Radeon Additional Settings> Power> Switchable Graphics Application Settings> Set power to maximize performance.

Also, to set applications go to:
Radeon Settings > Preferences > Additional Settings > Power > Switchable Graphics Application Settings
 

AbhijeetSingla

Prominent
Mar 26, 2017
15
0
510
0

Hey,
Thanks for answering, but I already checked that, it was indeed using the amd gpu, and to confirm that I ran Doom 2016, and checked the advanced stats, it said AMD R7 M360 was being used. Can you suggest something else?

 

ava3a13

Prominent
Apr 23, 2017
95
0
660
14

Do you have windows 8.1 installed on your notebook?
 

AbhijeetSingla

Prominent
Mar 26, 2017
15
0
510
0

I am running windows 10 pro 64-bit.
I think that should be able to run it?
 

ava3a13

Prominent
Apr 23, 2017
95
0
660
14


My guess is that it's your operating system. Yes your notebook can run it, but is it installed correctly?
 

AbhijeetSingla

Prominent
Mar 26, 2017
15
0
510
0

I think,
But how do I make sure?
 

akkdub

Prominent
Apr 27, 2017
2
0
510
0
Try to check your CPU/RAM/HDD usage from the task manager. I had the same issue, and it was my HDD spiking up to 100% usage. Mine was caused due to windows search indexing running in the background! Just check if that's the case for you
 

ava3a13

Prominent
Apr 23, 2017
95
0
660
14


Now try to check for drivers, do you have latest WHQL drivers installed on pc?
 

AbhijeetSingla

Prominent
Mar 26, 2017
15
0
510
0


How do I do that?
 

ava3a13

Prominent
Apr 23, 2017
95
0
660
14

You can download Driver Booster, it's free software and check for your drivers. Good luck!

 

AbhijeetSingla

Prominent
Mar 26, 2017
15
0
510
0


cpu at 60%
HDD at 70-80%
Ram 4gb used of 8gb
I don't think this is the issue.
 

AbhijeetSingla

Prominent
Mar 26, 2017
15
0
510
0

just did that, but my video adapter driver was up to date.
 

ava3a13

Prominent
Apr 23, 2017
95
0
660
14
That's not only about video adapter, that's also about other drivers. And by the way, have you downloaded your video adapter driver from AMD website?
 

AbhijeetSingla

Prominent
Mar 26, 2017
15
0
510
0

I had old drivers, installed those and yes I downloaded amd crimson from the amd site.
 

AbhijeetSingla

Prominent
Mar 26, 2017
15
0
510
0
The CPU hovers between 40-50%
The GPU stays at 980 mhz core clock
And 900mhz memory clock consistent
30% Ram used
40-50% HDD used
These are the stats while playing saints row the third which lags a lot.
 
Status
Not open for further replies.

Similar threads