Question Low/Very Low CPU usage in game.

Dec 6, 2020
3
0
10
0
Hi everyone,

First of all, thank you for reading me, It's my first time ever creating a thread and I hope you guys can help me figure out what's going on. I've been googling this for weeks now, but no solution could help me out.
When I bought my gear less than 2 years ago, I usually had around 70% usage of both CPU and GPU in intensive games such as Assassin's Creed Origins. I also had an average 280FPS on CSGO without any kind of fps drops but never monitored hardware while playing it. Everything was fine. I could run any game without worrying about temps and/or Harware usage.

I had a moment where I stopped playing these games and I started playing Valorant and a bit of League Of Legends. These were my main games. (I get and average 280-240 FPS in Valorant in max settings) But something like 4 weeks ago I wanted to get back to CSGO, and noticed that my FPS are around 60FPS ??? While monitoring my hardware on MSI afterburner, I could tell that my CPU Usage is around 7% on CSGO. Though, my GPU is permanently on 99% -98% ?? What the hell is going on ? I thought it was just CSGO going nuts. But I noticed that recently when I installed Genshin Impact, my GPU usage was VERY inconsistent staying at 60% some moments but spiking UP and DOWN from 99% to 0% Especially when teleporting to another part of the map, and I expercience a few Frame drops (2 to 6 FPS) every minute. I mean, this would not make me wonder if my gear was potatoe. But I am actually using a 1080ti with i7-8086K without any kind of OC on any of them.

Since I uninstalled Assassin's creed origins for a moment now, I still had MAFIA 3 to see if the same problem was up there. Well, CPU usage is at an average of 40% wich seems a bit lower than before...

I thought Benchmarking my hardware would help me figure out or at least make me feel better about my hardware health so I did :

-Benchmark my CPU on CINEBENCH : Latest score => 1420cb with consistent 100% cpu usage and a max temp of 60°C (Though my room is very cold)

-Benchmark my GPU on SUPERPOSITION Benchmark : Latest score => 5394 with Average FPS of 40.32, with consistent max usage 99% and highest temp at 65°C (Starting from 35°C)

I tried :
-DDU my graphic card drivers and reinstalling them manually (Improved a bit performance and genshin impact, but might be just placebo)
-Reinstalling windows without losing data and apps.

PS: I reinstalled windows because CSRSS.EXE was using 30% of the gpu's 3d processor when i was watching a stream on discord...

Thank you guys for any sort of help you're trying to come up with. And I hope this could help anyone else.

Me specs :
-Motherboard : ASUS PRIMES Z370-P
-CPU : i7-8086K (6C/12T)
-GPU : Gigabyte 1080ti Gaming OC (No manual Overclocking ever done)
-RAM : 4x8GB DDR4
-SYSTEM DRIVE : Samsung M.2 SSD
-SECONDARY DRIVES : Additional Intel M.2 SSD + 2To Western digital Black 7200RPM + 1To Western Digital Black 7200RPM
 

Lutfij

Titan
Moderator
When you reinstall the OS, you're advised to do so armed with an installer made with Windows Media Creation Tools. Before you go ahead and reinstall the OS, make sure you're on the latest BIOS update for your motherboard. If you've got a number of BIOS versions to work through, gradually work your way to the latest version taking note of any Intel MEI installers in between.

Once the BIOS end is up to date, reinstall the OS. Then install all drivers manually in an elevated command.

You forgot to mention the make and model of your PSU and the cooler that's keeping that processor cool.
 
Dec 6, 2020
3
0
10
0
Hi Lutfij,

You forgot to mention the make and model of your PSU and the cooler that's keeping that processor cool.
Thanks for stopping by. Sorry about the missing specs. Here they are :

-Liquid Cooler : Be quiet! Silent Loop 240mm
-PSU : Be quiet! Pure Power 10. 700W


I had serious troubles with my AIO that made my CPU overheat 2 months ago, and I figured out it was blocked inside once I completely disambled it. So I Filtered the liquid twice with coffee filter and added a bit of distilled water to fill it up completely, and that made me get better FPS on valorant...

When you reinstall the OS, you're advised to do so armed with an installer made with Windows Media Creation Tools.
I actually did use the WMCT to create the iso image. And as mentionned earlier I chose to reinstall OS but to keep apps and data. Do you think a fresh blank reinstall would be worth a try ?

Before you go ahead and reinstall the OS, make sure you're on the latest BIOS update for your motherboard. If you've got a number of BIOS versions to work through, gradually work your way to the latest version taking note of any Intel MEI installers in between.

Once the BIOS end is up to date, reinstall the OS. Then install all drivers manually in an elevated command.
I thought about upgrading my BIOS but it just seemed a bit tricky and I didn't want to risk anything to be honest, especially because I have some custom parameters that I made 2 years ago for my SSD and HDD compatibilities that I honestly can't remember, and I'm just afraid not to find them again since I read that I have to put on the Bios parameters manually again after and update. (Though, I never upgraded my BIOS and things were just fine..)

I would also like to ask you if it is normal to get a 20 - 30% GPU Usage while watching just netflix and everything else is idle ? GPU clocks though are very low. (around 400 MHz). And the usage is on the 3D engine Processor. Shouldn't it be on the Video Decode Engine while watching videos ? I'm asking this because it's the same while watching discord streams.

Sorry if I am overexplaning but I am really getting more and more lost. And I really can't find answers...

Thank you again for your time!
 

ASK THE COMMUNITY

TRENDING THREADS