Question Memory Instability, underclocked RAM.

stchman

Distinguished
Oct 7, 2012
110
1
18,685
0
Hello all. I have a system I put together about 2 years ago.

My PC has the following specs:

Gigabyte B450M DS3H
AMD Ryzen 5 2600
G.Skill Aegis 16GB (2 x 8GB) DDR4-3000 PC4-24000 CL16
MSI GTX 1660 Video Card.
PowerSpec 650W Power Supply

I bought all of the components at Microcenter, here is the RAM.

https://www.microcenter.com/product/474187/gskill-aegis-16gb-(2-x-8gb)-ddr4-3000-pc4-24000-cl16-dual-channel-desktop-memory-kit-f4-3000c16d-16gisb-black-red

I recently updated the UEFI on the motherboard. When running the RAM at 3000, I get errors running Memtest86 and unstable behavior(locking up in Windows and Linux) I underclocked the RAM down to 2666 and the errors seemed to have gone away, no errors in Memtest86.

I am running the profile in the UEFI and I simply select a lower multiplier for the RAM to underclock.

I have contacted G.Skill, but if anyone on the forum has any suggestions, please.

Thanks.
 

stchman

Distinguished
Oct 7, 2012
110
1
18,685
0
After the Bios update did you also update the Chipest drivers, they kinda go hand in hand and certainly worth a try. Just go to AMD and update the latest for your B450 chipset.
Should I get the drivers from Gigabyte website or directly from AMD?

I was also under the impression that Windows 10 had the drivers for the chipset.
 

Schlachtwolf

Respectable
Chipset drivers that are designed to support the new Bios features will give you more stability for sure, you won't see more FPS or higher benchmarks. Chipset drivers are there for system stability, RAM is where Ryzen is most picky, so while it runs at default speed if the instructions that bios is giving and the chipset converts are slightly out of sync then it runs at default and DOCP is unstable.

Be sure to let us know if this solution worked for you....
 

stchman

Distinguished
Oct 7, 2012
110
1
18,685
0
Chipset drivers that are designed to support the new Bios features will give you more stability for sure, you won't see more FPS or higher benchmarks. Chipset drivers are there for system stability, RAM is where Ryzen is most picky, so while it runs at default speed if the instructions that bios is giving and the chipset converts are slightly out of sync then it runs at default and DOCP is unstable.

Be sure to let us know if this solution worked for you....
So far so good. Granted, I use Windows 10 only occasionally, usually only for gaming. I primarily use Linux Mint 20 and before I underclocked the RAM I would get occasional freezes.

As far as updating chipset drivers in Linux, the kernel should have all the drivers.
 

Schlachtwolf

Respectable
Updating the Chipset drivers has nothing to do with Windows or Linux, they are Bios system drivers and not on your desktop driving stuff drivers if you get what I mean. So the Chipset drivers for Win10, Linux are the same. I would now remove the underclock from the RAM, activate DOCP and get the RAM to run at 3000mhz, it should now be stable.
 
Reactions: helper800

stchman

Distinguished
Oct 7, 2012
110
1
18,685
0
Updating the Chipset drivers has nothing to do with Windows or Linux, they are Bios system drivers and not on your desktop driving stuff drivers if you get what I mean. So the Chipset drivers for Win10, Linux are the same. I would now remove the underclock from the RAM, activate DOCP and get the RAM to run at 3000mhz, it should now be stable.
So you're trying to say that if/when I install AMD B450 drivers in Windows 10 it actually updates the BIOS chipset drivers?
 

stchman

Distinguished
Oct 7, 2012
110
1
18,685
0
Yes it is there for the CPU chipset instruction and not directly to do with the OS system in use at the time.
I installed the AMD chipset drivers:
https://www.amd.com/en/support/chipsets/amd-socket-am4/b450

I selected Windows 10.

I went back into the BIOS and used the profile that does full speed on RAM. I ran another memtest86 and still got errors. I underclocked the RAM to 2933 and memtest86 reports no more errors on all 13 tests.
 

Schlachtwolf

Respectable
Seems the VRM's on your board are not handling 3000mhz too well with the new BIO's which is odd but at least you are up to 2933mhz stable as opposed to 2666mhz, so no real application would notice 67mhz less anyway but it is an odd issue. The reason I think this is a VRM issue (bios caused voltage mis-read or heat/both?) is the underclock drops the voltage and therefore heat generated.
 

Vic 40

Titan
Ambassador
Maybe the memory controller on the cpu is abit weak in your cpu. Could try and add some voltage to the ram and the SoC , se if that helps.

In the MIT under Advanced Voltage Setting change the ram=Dram Voltage set it at 1.4V , for the Vcore SoC (see pic) set it at 1.15V test,
Can try each on it's own. This should't hurt your system. You can always set them back.


 

stchman

Distinguished
Oct 7, 2012
110
1
18,685
0
G.Skill contacted me. It turns out that I was putting the RAM in the wrong slots. I was always lead to believe that you should always populate RAM pairs in the slots closest to the CPU. Gigabyte recommends that you use the RAM slot pairs furthest away from the CPU if using only one pair

I re-located the RAM and ran Memtest86 again with the RAM running at Profile 1 (3000Mhz). The RAM passed all 13 tests. I thought that all was solved. When booting into Windows 10, everything seems to run just fine. When I boot into Mint 20, I am still getting erratic behavior. I had to set the RAM speed back down to 2933Mhz again and all is well.

It's no big deal, but just that this is peculiar.
 

stchman

Distinguished
Oct 7, 2012
110
1
18,685
0
Not slots furthest away, slots 2+4 from the cpu out, in the manual referred as A2+B2.
On page 4 of the motherboard manual there are 4 RAM slots next to CPU.

CPU DDR4_4 DDR4_2 DDR4_3 DDR4_1

I had RAM in DDR4_4 and DDR4_3 (slots closest to CPU)

On page 10 of the motherboard manual:

When enabling Dual Channel mode with two or four memory modules, it is recommended that memory of the same capacity, brand, speed, and chips be used.

For optimum performance, when enabling Dual Channel mode with two memory modules, we recommend that you install them in the DDR4_1 and DDR4_2 sockets.
 

Vic 40

Titan
Ambassador
CPU DDR4_4 DDR4_2 DDR4_3 DDR4_1

I had RAM in DDR4_4 and DDR4_3 (slots closest to CPU)


For optimum performance, when enabling Dual Channel mode with two memory modules, we recommend that you install them in the DDR4_1 and DDR4_2 sockets.
You had them in the red (?) when they should be in the green.

G.Skill contacted me. It turns out that I was putting the RAM in the wrong slots. I was always lead to believe that you should always populate RAM pairs in the slots closest to the CPU. Gigabyte recommends that you use the RAM slot pairs furthest away from the CPU
When you say it like this it sounds like you had them in 3+1.
 

Karadjgne

Titan
Ambassador
Back in the day you had 2 buss systems, 100MHz and 133MHz. With ram, everything since then is basically just a multiplier of those. Most boards are accepting of either, but have a preference for 133MHz. Some boards only do 133MHz.

2933MHz is a 133MHz x22 multiplier.
3200MHz is a 133MHz x24 multiplier.
3000MHz is a 100MHz x30 multiplier. So every now and then ppl run into issues with 3000MHz, especially with Ryzens. It's recommended that you set XMP/DOCP and then manually change the ram speed to 2933MHz and set fclock for 1466MHz. In many bios its listed as 200/266 instead of 100/133, but the affect is the same, only a 11x or 12x multiplier for 2933/3200 but a 15x multiplier for 3000 and Ryzens don't like odd numbers much.
 

ASK THE COMMUNITY