Memory speed not right

nem2k

Distinguished
Nov 20, 2006
220
0
18,680
0
when I boot up the computer on the post screen it says my memory is PC4300

however in the bios ive set the memory to run at 400mhz, which should be pc6400 (this was the speed of memory i bought as well)

when i set everything to auto in the bios, during post it says im running pc6400, but now ive set the memory to 6400 speed and it still says im at 4300, anyone know why?
 

Mondoman

Splendid
Jun 22, 2006
5,678
0
25,810
5
Your post is very confusing. DDR effective speeds are given as e.g. DDR-400 or PC-3200 (PC = 8 x DDR value). DDR2 effective speeds are given as e.g. DDR2-533 or PC2-4300. You also need to keep in mind the difference between what speed your memory is rated at and what speed it is actually running at.
I'm guessing that you have DDR2 RAM. Normally, one uses the effective memory speed number (DDR2-xxx) to set the memory speed in the BIOS. Thus, using a speed of 400 probably set your RAM to DDR2-400 or PC2-3200. This speed is probably too slow for your DDR2, and so the system sets it to DDR2-533/PC2-4300.
 

nem2k

Distinguished
Nov 20, 2006
220
0
18,680
0
ok ill try to explain better

yes i have DDR2 ram. ive set the speed to 800mhz...which would make it equivalent to PC6400 right?

but even with the speed set to 800, the initial startup screens says i have PC4300 which is obviously slower than what i set...
 

Mondoman

Splendid
Jun 22, 2006
5,678
0
25,810
5
In your earlier post, you said you had set it to 400MHz, not 800MHz. :?

I think it will be better if you list the model numbers of all the components in your system, and tell us *exactly* what you did (i.e. what you type at which screen).
 

nem2k

Distinguished
Nov 20, 2006
220
0
18,680
0
sorry ignore the initial 400 (i was still in fsb mode from overclocking that), the memory is set to 800mhz, but still shows as PC4300...
 

Mondoman

Splendid
Jun 22, 2006
5,678
0
25,810
5
Please list the model numbers of your MB, RAM and CPU. What exactly do you mean by "the memory is set to 800MHz"? How exactly did you do this? Where exactly does it "show" as PC2-4300?
 

nem2k

Distinguished
Nov 20, 2006
220
0
18,680
0
c2d e6600
p5b deluxe
corsair pc6400C4

so i set the fsb to 400mhz, set the ram frequency to 800 in the bios

but when the computer first boots, on the black screen it says it detects 2gb of PC4300 ram...
 

Mondoman

Splendid
Jun 22, 2006
5,678
0
25,810
5
It sounds like it is reporting 2gb of RAM *running at* PC2-4300. Remember that your RAM's SPD contains profiles for at least a few different speeds. Perhaps your system isn't stable at a FSB of 400MHz, and so the BIOS restores everything to a safe, slower speed. Will your system run at DDR2-800 at the standard FSB of 267MHz?
 

nem2k

Distinguished
Nov 20, 2006
220
0
18,680
0
hm well heres an interesting thing

i set my fsb to 266, and DDR2-800...the initial startup screen reports PC2-6400....so that works

but when i set fsb to 266, DDR2-533 to maintain a 1:1 ratio, and then slowly increase the fsb to 400 and DDR2-800, the startup screen still reports PC2-4300
 

Mondoman

Splendid
Jun 22, 2006
5,678
0
25,810
5
well with fsb400, prime95 says my system is stable

and yes, running DDR2-800 with 266FSB is perfectly stable
By these, do you mean that you are running 2 copies of PRIME95 with each copy's affinity set for a different core, and that you are running the torture test "blend" mode (some CPU, but also memory)?
 

nem2k

Distinguished
Nov 20, 2006
220
0
18,680
0
yes to all of that. ive also run both blend and large torture tests on seperate occasions, didnt crash in hmm, at least 21 hours
 

nem2k

Distinguished
Nov 20, 2006
220
0
18,680
0
heres a question, PC2-4300 and PC2-6400...what exactly are the differences? is it just the frequency?

because the initial startup screen reports 4300....but when i open up cpu-z, it says my frequency is equivalent to 6400...so which am I actually running at? :?
 

Mondoman

Splendid
Jun 22, 2006
5,678
0
25,810
5
....
but when i set fsb to 266, DDR2-533 to maintain a 1:1 ratio, and then slowly increase the fsb to 400 and DDR2-800, the startup screen still reports PC2-4300
Does this mean that you set the memory speed to DDR2-533 and FSB to 266, and it shows PC2-4300 memory speed?
Then, after that, what exactly do you mean by "...then slowly increase the fsb to 400 and DDR2-800,..."? Do you increase first one, then the other, both at the same time, by how much, etc?

Perhaps your system uses "DDR2-533" to represent a multiplier of the FSB freq, not the true memory bus speed. Thus, "DDR2-533" would represent 1:1 vs the FSB. If you increased the FSB to 400MHz, the memory would then really be running at DDR2-800, even though set at "DDR2-533".

I don't know your BIOS; if this isn't covered in the MB manual, you'll have to talk with Asus tech support or someone else familiar with how your board represents overclocking parameters.
 

nem2k

Distinguished
Nov 20, 2006
220
0
18,680
0
Perhaps your system uses "DDR2-533" to represent a multiplier of the FSB freq, not the true memory bus speed. Thus, "DDR2-533" would represent 1:1 vs the FSB. If you increased the FSB to 400MHz, the memory would then really be running at DDR2-800, even though set at "DDR2-533".
i think thats exactly whats going on. i keep the ratio at 1:1 so fsb is 400, and memory running at DDR2-800, thats how ive set it up in the bios

but i dont understand what you mean DDR2-533 representing a multiplier...

what i want to know, is my ram is rated to run at PC2-6400...in my system atm, is it being underclocked? i want it to run at full speed
 

zjohnr

Distinguished
Aug 19, 2006
577
0
18,980
0
What speed does CPU-Z ... or any other good system info grabbing utility ... say your memory is running at? (CPU-Z will also tell you what's in the memory's SPD).

link to CPU-Z webpage

link to PC Wizard 2007 webpage

(No, I'm not sure exactly what PC Wizard is all about. Seems to be a more involved version of CPU-Z that requires an install, but returns more system info. CPU-Z is very portable ... no need to "install" it).

-john, the ostensibly clueless redundant legacy dinosaur
 

nevesis

Distinguished
Oct 27, 2006
102
0
18,680
0
my ram is kingston 667, and on post it reports my ram as pc-4300 as well, but its actually pc-5300, and in CPU-Z it shows 1:1 @ 333mhz, must be some asus problem? in the post.
 

zjohnr

Distinguished
Aug 19, 2006
577
0
18,980
0
my ram is kingston 667, and on post it reports my ram as pc-4300 as well, but its actually pc-5300, and in CPU-Z it shows 1:1 @ 333mhz, must be some asus problem? in the post.
I have no idea what might cause the PC-4300 report during POST.

The 333MHz from CPU-Z means your memory is running at stock DDR2-667 speed. CPU-Z reports the frequency the underlying bus is working at which for DDR2-667 is 667/2 = 333. (Curse the industry and their sometimes misleading naming conventions! :evil:)

If CPU-Z says 333MHz is 1:1 then it sounds like your FSB is also running at 333MHz, not 400Mhz (which I thought I saw in any earlier post). :? Is 333MHz what CPU-Z reports as the "Bus Speed" under the "CPU" tab?

-john, the ostensibly clueless redundant legacy dinosaur
 

nem2k

Distinguished
Nov 20, 2006
220
0
18,680
0
yeah i have pretty much the same problem as nevesis, just different numbers

and in CPU-Z....bus speed says 400mhz, and under the memory tab, the frequency says 400mhz as well which would clearly indicate its PC2-6400...but post says otherwise which is why im confused as to what frequency im actually running on the memory
 

zjohnr

Distinguished
Aug 19, 2006
577
0
18,980
0
yeah i have pretty much the same problem as nevesis, just different numbers
Arrrrgh! Now I get it. Two different posts from two different people with two different memory clockings, but both show PC4300 at boot.

I have not a clue. But at least it does sound as though after POST the systems are running at speeds you expect them to.

:?: Perhaps the POST starts out with both FSB and memory bus running at the stock 266MHz (PC2-4300) and then later in the boot process, after the flakey report, does the BIOS switch the bus speeds to what you have selected in the BIOS? :?:

If you're curious, probably the best thing to do is ask Asus about it? :?

-john, the ostensibly clueless redundant legacy dinosaur
 

nem2k

Distinguished
Nov 20, 2006
220
0
18,680
0
yeah ill pass on asking asus, im not a big fan of their customer service

but as long as cpu-z reports that my memory frequency is 400mhz, then i should be running at the advertised pc2-6400 speed right and have nothing to worry about even though post says otherwise?
 

zjohnr

Distinguished
Aug 19, 2006
577
0
18,980
0
but as long as cpu-z reports that my memory frequency is 400mhz, then i should be running at the advertised pc2-6400 speed right and have nothing to worry about even though post says otherwise?
That is a question I'm not actually qualified to answer. Of course, I think that this is the case. I just can't state that I know it is true.

If you've still got doubts I think Intel has a utility that will tell you how fast their processor is running. There are lots of (freeware) system information tools available from different sources on the web.

-john
 

Similar threads


ASK THE COMMUNITY