Question Monitor loses signal, amd software not compatible after restart. Only when playing games

Sep 19, 2022
5
0
10
0
Hi, so I recently bought a rx 550 and replaced my previous gt 710 and the installation was fine. When I play a game though my monitor just suddenly loses signal and I'm pretty sure the game stops even though I hear my friend's voices. After restarting my pc resolution is lowered and fixed as if I never installed the drivers and amd's adrenaline software isn't compatible. I even checked gpuz in that state and still said I had a rx 550. To go back to normal I had to reinstall drivers but still have the same issue even if I use different versions. I also reinstalled my gt 710 and so far didn't really have any problems up til now. I returned the rx 550 to the store and they tested it and nothing was wrong on their end. I'm planning to buy another unit or a different gpu, and I'm worried I'll have the same issue.

My specs:
Processor: I3-9100f
MOBO: Biostar H310M
Ram: HyperX Fury 2x8 2400 mhz
PSU: Trigon 700w
 
Hi, so I recently bought a rx 550 and replaced my previous gt 710 and the installation was fine. When I play a game though my monitor just suddenly loses signal and I'm pretty sure the game stops even though I hear my friend's voices. After restarting my pc resolution is lowered and fixed as if I never installed the drivers and amd's adrenaline software isn't compatible. I even checked gpuz in that state and still said I had a rx 550. To go back to normal I had to reinstall drivers but still have the same issue even if I use different versions. I also reinstalled my gt 710 and so far didn't really have any problems up til now. I returned the rx 550 to the store and they tested it and nothing was wrong on their end. I'm planning to buy another unit or a different gpu, and I'm worried I'll have the same issue.

My specs:
Processor: I3-9100f
MOBO: Biostar H310M
Ram: HyperX Fury 2x8 2400 mhz
PSU: Trigon 700w
If you still have the rx 550, try to install regular drivers (22.8.2) and uninstall them using DDU. then try Amernime Zone driver (22.8.2 for polaris, install the default 22.8.2 ones)

then try to post a gpuz screenshot here.
 
Sep 19, 2022
5
0
10
0
If you still have the rx 550, try to install regular drivers (22.8.2) and uninstall them using DDU. then try Amernime Zone driver (22.8.2 for polaris, install the default 22.8.2 ones)

then try to post a gpuz screenshot here.
I did use DDU before installing the new gpu, and everytime I had to reinstall the drivers. One of the drivers I tried was also a regular one and it lasted a little bit longer but it still had the same issue.
 

ASK THE COMMUNITY

TRENDING THREADS