• Now's your chance to speak with MSI directly! Join our AMA and get entered to win a RTX 2060 GPU, plus more! Ask your questions here.

    Catch the next Tom's Hardware livestream on May 28 at 2PM Eastern: Catch the show here!

    Need Hardware Help? Include the Info Requested Here.
  • Join our Best PC Builds competition and get on the Tom's Hardware home page. Check it out here.

Question Motherboard won't use all RAM (but can detect it)

Nov 8, 2019
1
0
10
0
Hello,

I will start with my specs:
Mainborad: ASRock B75 Pro3 (BIOS ver P.20 - according to page of my mobo it is newest UEFI version that I can install)
Memory: CMZ8GX3M2A1600C9 (details in screenshots below)
CPU: Intel Core i5 3470
GPU: Radeon RX 480
OS: Windows 10 (64bit)

Today I expanded my PC with 2 additional RAM sticks (I had 2x 4GB and I bought extra 2x 4GB). Unfortunately something is not working correctly because I can see that only 8GB is beeing used. New RAM sticks that I bought have same part number as old ones and same frequency, CL, they work with same voltage etc. -on little sticker on the back, all RAM sticks have 1600 9-9-9-24 1.50V written.
After I installed new RAM sticks, there was no increase in RAM in Windows, so I checked UEFI and I could see that slots A2,B2 were occupied with old sticks and slots A1,B1 were "empty". I chcecked every single RAM stick separately and every single RAM slot and everything is working correctly. When I use only new RAM sticks then I still have 8GB of RAM, I even chcecked and put 1 new and 1 old stick and they were also working fine - 8gb in dual-channel (dual-channel shows also with all 4 sticks installed). Also when I put all sticks inside then only slots A2, B2 are used but when I take out A2 OR B2 (so I have 3 sticks in total) then slots A1 and B1 are working and other slot is "empty".
When I go to "System Browser" tool in UEFI then I can see that all RAM slots are occupied so UEFI can detect them, but they are still not beeing used. When I go to CPU-Z to "Memory" tab then I can see that I have 16GB RAM and in "SPD" tab I can check detail about each RAM stick (so CPU-Z can detect it).
What I also did: Reseted UEFI to defaults (multiple times), I reseted CMOS with pins and tried various RAM configurations but nothing helps.
In Windows (msconfig) there is no limitation set regarding RAM amount and I turned off page files (I found those solutions on net but they didn't help)
I tried increasing and decreasing voltage for DRAM and VTT, fixed various RAM settings to fixed values (frequency, CL, tRCD, tRP, tRAS) instead of having it on auto.
Below I will add some screenshots from CPU-Z,pictures from UEFI and 1 picture from Resource Monitor (it is in polish but I added translation).

Does anyone know what can be a solution to my problem?

I noticed that in the UEFI screens I have new sticks in slots A1, A2 and old sticks in B1, B2 but in CPU-Z it is different. As I said I tried many different configurations (and pictures/screensots are from different configurations) and always slots A2, B2 take priority (no matter what sticks are in them). Also all pictures were done with all 4 RAM sticks installed.

CPU-Z:
Mainborad:


Memory:


SPD:





UEFI:


System Browser:





Resource Monitor:
 
Last edited by a moderator:
Corsair as well as other memory manufacturers don't guarantee compatibility together when adding extra memory, multiple kits.

Your results are typical of such combinations. You are free to make any kind of combinations you want and do your own compatibility testing with no guarantees.
 

gasaraki

Distinguished
Jun 11, 2008
1,297
14
19,665
125
There must be some configuration in the BIOS somewhere causing this. You already said you tried every combination like mixing the old and new RAM so it not the combination of old and new that's causing the issue. Let do some more digging and see if I can find the issue.
 

gasaraki

Distinguished
Jun 11, 2008
1,297
14
19,665
125
I have looked in to the manual of your motherboard and they want people to use identical memory for all 4 slots. Unfortunately the 2 new sticks you got are NOT exactly the same as the old memory, even though they have the model numbers and speed and timing ratings. One set of memories are single ranked and the other set is dual ranked. Also the sub-timings are not exactly the same. So maybe you're out of luck.
 

ASK THE COMMUNITY

TRENDING THREADS