Question My HyperX Pulsefire Haste keeps disconnecting

arn19531

Reputable
Dec 6, 2018
8
0
4,510
0
So I bought the Hyperx Pulsefire Haste wired mouse and it has served well for over 6 months. But recently while playing anything or literally just moving the mouse too fast makes it disconnect.
I have disabled the "allow the computer to put this device to sleep to save power" from device manager and devices and printers which did not solve the issue.
I have done every sort of update, troubleshoot or any firmware update I can find for my mouse. DID NOT WORK.
The mouse still disconnects when it is moved fast.
I also can clarify that my mobo or any of the usb slots are not faulty. I have used other mice and those ones had no problems and ran smoothly.
As a last attempt to see if it's the mouse's fault I plugged it into my brothers computer and laptop. And it seems it works smoothly on those computers.
I want to know if there is a solution for this, especially since this only happens to my PC and mine only. Is there anything else I can do, any solution I overlooked cause I am confident I have tried every solution I can find on the internet and none of them seems to bear any fruit. Heck I even reset my whole windows.
 

Lutfij

Titan
Moderator
The mouse still disconnects when it is moved fast.
Have you tried seeing if the issue can be replicated with you just moving the mouse cable without moving the mouse? A frail soldering on the mouse's end could be the culprit.

You could try and relocate the mouse to the front panel of your case to see if the issue persists. Maybe try and reinstall your chipset/USB drivers. Lastly, what is the make and model of your motherboard and subsequent BIOS version at this moment of time? What OS are you working with?

Heck I even reset my whole windows.
Resetting doesn't do anything, if you reinstalled your OS, then that would mean you might have a driver or a motherboard issue.
 

arn19531

Reputable
Dec 6, 2018
8
0
4,510
0
The mouse still disconnects when it is moved fast.
Have you tried seeing if the issue can be replicated with you just moving the mouse cable without moving the mouse? A frail soldering on the mouse's end could be the culprit.

yes i have tried this and that is not the problem, the mouse doesn't dc when the wire or cable is moved

You could try and relocate the mouse to the front panel of your case to see if the issue persists. Maybe try and reinstall your chipset/USB drivers.

Yes, I also tried relocating to every port n the pc but the problem still persists. And also checked my usb driver and chipset driver, checked AND reinstalled them just to be sure.

Lastly, what is the make and model of your motherboard and subsequent BIOS version at this moment of time? What OS are you working with?

Heck I even reset my whole windows.
Resetting doesn't do anything, if you reinstalled your OS, then that would mean you might have a driver or a motherboard issue.

for the make and model of bios here is a screenshot of my system information
https://drive.google.com/file/d/1_Ef9w0fUg0wLtMihDMUrzE6lBh-vkVuS/view?usp=share_link
 

arn19531

Reputable
Dec 6, 2018
8
0
4,510
0
If you're indeed on 7C52v36(doublecheck by going into BIOS screen), then you have BIOS updates pending. The same goes for your OS.
I just updated my BIOS and OS and it still didn't stop
Just played a game and the expeience was miserable

The funny thing is this mouse only has this problem with my pc only
 

arn19531

Reputable
Dec 6, 2018
8
0
4,510
0
If you're indeed on 7C52v36(doublecheck by going into BIOS screen), then you have BIOS updates pending. The same goes for your OS.
so i updated the bios and os but it didn't have any change
i think that the mouse isnt compatible with my pc or smth might just buy a new one ig
 

ASK THE COMMUNITY