[SOLVED] Need to reseat ram everytime PC power is completely shut off

May 28, 2020
7
0
20
1
I just recently upgraded my system to an Asus z490-e motherboard with a 10900k. The first few days, the computer was working fine other than a few blue screens due to me messing with overclocking.

Today, I booted up my computer and it went straight into bios and it doesn’t even recognize my Intel 660p m.2 in there. After some trouble shooting, I reseated my m.2 and it finally worked again.

Everything was working fine for a little until I shut it off normally and switched off the power supply. Same issue again. I reseated the m.2 and it started working fine again.

After some testing I realized that whenever power to my system is completely cut (hard reset/power supply switched off/Unplugging the machine) I need to reseat my m.2 for it to work again.

Im at a loss as to what is the reason for this issue. I’ve searched over the internet for this but have found nothing. Is this an issue with the motherboard? M.2? Bios issue? Or what?
Please help

CPU- i9 10900k
Motherboard- Asus Strix z490e
Power supply- Evga 850 gq
GPU- Asus Strix 2080
Ram- 48 Gigs Corsair Vengeance rgb 3200mhz
Storage- Intel 660p 1tb
OS- Windows 10 build 18362
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS