[SOLVED] Network Error: Windows cannot access \\pc-name (network sharing)

subhranshu50

Prominent
Nov 16, 2017
15
0
510
0
I recently got a very odd problem with Windows 10 network sharing. When I open my shared folder in "Network" from "this pc" it says "Windows cannot access \\pc-name\folder-name\."

I have turned on network discovery and file sharing for all the network types (private, guest, public) and I have also given permissions in folders sharing property. I'm able to access the other PC that is connected on the same network on my laptop (that has this problem) but that working PC does not see my laptop on the shared network, though both the laptop and PC are in same work group and network.

After running the troubleshooter, it says the remote device or resource won't accept the connection. Please help with this issue, i have tried the majority of the methods to fix this but nothing works, it's like the network feature doesn't even exist on my Windows now as it is not being discovered anywhere.
 
Last edited by a moderator:
May 23, 2018
1
0
20
1
i used Tweaking.com - Windows Repair which restored registries and and various other Windows files and then i uninstalled the majority of the programs and then restarted and again tried to double click on my PC name from networks in this PC and it still showed the same error: path cannot be found.

But, then I was really fed up and gave one last try, i removed the home-group from every system on my network and ran home-group troubleshooter, nothing happened from the troubleshooter but then I created a new home-group on my laptop after removing the home-groups from every system and now, when I double clicked on my PC name in networks, the shared folder opened.

Also, when I tried same on another system in the same network, it opened there too, so I think just by removing home-groups from every system and making a new home-group from your system would work. Maybe also disabling every service using the network such as xampp and filezilla.
 
Last edited by a moderator:

subhranshu50

Prominent
Nov 16, 2017
15
0
510
0
thank you for replying bajgur

this is what i get after ping pc-name

ping pc-name

Pinging pc-name [192.168.0.100] with 32 bytes of data:
Reply from 192.168.0.100: bytes=32 time<1ms TTL=128
Reply from 192.168.0.100: bytes=32 time<1ms TTL=128
Reply from 192.168.0.100: bytes=32 time<1ms TTL=128
Reply from 192.168.0.100: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.0.100:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms
 

bajgur

Respectable
Nov 29, 2016
279
0
1,860
36
what version of windows 10 youre using?
the latest one has removed homegroup.

go to 192.168.0.100 make sure that youre sharing D.
right click D folder -> properties -> sharing -> advanced sharing -> check "share this folder" -> click permissions -> give everyone full control.
 

subhranshu50

Prominent
Nov 16, 2017
15
0
510
0
i am using the latest version of windows 10 home with latest updates installed and i have shared the d folder with all the permissions, to be sure i shared one more folder and added everyone in the permissions tab and also gave full access to that still i am getting this error (by 192.168.0.100 you mean my pc right which is pc-name)
 

R0GG

Distinguished
Dec 27, 2012
1,232
2
19,965
252
- Disable the discovery/sharing on both PC,
- verify Both connection are labeled as home network
- Both computers : System > advanced setting > rename this computer or change it's domaine = put in new work group name
- Activate file sharing and discovery for both computers
Usually you do not need computer to join a home group as they already belonging to the same work group
 

subhranshu50

Prominent
Nov 16, 2017
15
0
510
0
thank you for replying rogg

to be clear the problem is not in the network or another system the problem is in my laptop, when you go to this pc>network>your pc name>shared folder, you will be able to access the folder that you have shared from there but in my case i am not able to open the folder from my pc itself, when i go to network>pc-name>sharedfolder, it says windows cannot access \\ but when go to that folder directly from my drive it opens up.
 

subhranshu50

Prominent
Nov 16, 2017
15
0
510
0
Hi,


Let's verify if these services are started.
a. Press Windows key + R.

b. Type 'sevices.msc' and hit ENTER.

1. DHCP Client

2. DNS Client

3. Network Connections

4. Network Location Awareness

5. Remote Procedure Call (RPC)

6. Server

7. TCP/IP Netbios helper

8. Workstation

9. Function Discovery Resource Publication,

10. UPnP Device Host services

All of these services should be started, and their startup type should be automatic.




i have tried this too
 
May 23, 2018
1
0
20
1
i used Tweaking.com - Windows Repair which restored registries and and various other Windows files and then i uninstalled the majority of the programs and then restarted and again tried to double click on my PC name from networks in this PC and it still showed the same error: path cannot be found.

But, then I was really fed up and gave one last try, i removed the home-group from every system on my network and ran home-group troubleshooter, nothing happened from the troubleshooter but then I created a new home-group on my laptop after removing the home-groups from every system and now, when I double clicked on my PC name in networks, the shared folder opened.

Also, when I tried same on another system in the same network, it opened there too, so I think just by removing home-groups from every system and making a new home-group from your system would work. Maybe also disabling every service using the network such as xampp and filezilla.
 
Last edited by a moderator:

R0GG

Distinguished
Dec 27, 2012
1,232
2
19,965
252
That's exactly what I did couple of time with my Seagate satellite drive shared folders, I had to erase previous home group and either create a new home group or other option I prefer is to just change windows default network going with each PC name and showing in the computer properties as default.
Great news then, thanks for your feedback.
 

ASK THE COMMUNITY

TRENDING THREADS