Question New build, no display.

Aug 21, 2020
2
0
10
0
Just put this together. Fans and lights are on. GPU fans at 100%. Tried HDMI and DP, still no display. GPU is from a previous build and is working. Any suggestions?

CPU: AMD Ryzen 5 3600 3.6 GHz 6-Core Processor ($179.99 @ Best Buy)
CPU Cooler: CRYORIG H7 Quad Lumi 49 CFM CPU Cooler
Motherboard: Gigabyte B550M AORUS PRO Micro ATX AM4 Motherboard ($129.99 @ B&H)
Memory: Gigabyte AORUS RGB 16 GB (2 x 8 GB) DDR4-3200 CL16 Memory
Storage: Samsung 850 EVO-Series 250 GB 2.5" Solid State Drive ($107.99 @ Adorama)
Storage: Gigabyte AORUS RGB 512 GB M.2-2280 NVME Solid State Drive ($119.99 @ Amazon)
Storage: Western Digital Caviar Blue 1 TB 3.5" 7200RPM Internal Hard Drive ($37.19 @ Amazon)
Video Card: Zotac GeForce RTX 2060 SUPER 8 GB GAMING AMP Extreme Video Card ($849.00 @ Amazon)
Case: Tecware Nexus M MicroATX Mid Tower Case
Power Supply: SeaSonic M12II 650 W 80+ Bronze Certified Semi-modular ATX Power Supply
Operating System: Microsoft Windows 10 Pro OEM 64-bit ($139.88 @ Other World Computing)
Monitor: Asus VP249QGR 23.8" 1920x1080 144 Hz Monitor
 

novathunder

Distinguished
Dec 31, 2007
16
3
18,515
0
Does it POST? If not try resitting RAM modules, they may not be fully inserted. Usually when RAM are inserted correctly computer will either POST or emit a series a beeps. Also take note some BIOSes needs to have keyboard plugged in to POST.
 
Aug 21, 2020
2
0
10
0
Does it POST? If not try resitting RAM modules, they may not be fully inserted. Usually when RAM are inserted correctly computer will either POST or emit a series a beeps. Also take note some BIOSes needs to have keyboard plugged in to POST.
Hi, so sorry for the late response. I actually took it to the store and they were unable to make it work initially, even with other GPUs. However, we updated to the latest BIOS and got it to work with a Gigabyte GPU but it still doesn't work with the Zotac 2060 Super. They tried several other GPUs including a Zotac 2070 and they were all working. It's just the GPU I got that's not. Not really sure what to do from here. I figure I could wait for another BIOS update but it may still not work after. The 2060 Super is working because I'm using it now on my older build(MSI H110M+i5 6500). On the other hand, I could just sell the GPU but no one's interested right now because of the 30-series launch.
 

ASK THE COMMUNITY

TRENDING THREADS