New computer not showing, most likely mobo issues.


Jun 17, 2011
Hi, I recently bought a new barebones package off tigerdirect and a GPU off newegg. Upon assembly, the computer runs fine, all internal LEDs light up. However, the monitor doesn't display anything

ASUS m5a99x evo motherboard
AMD FX-6100 x6 3.3GHz
1TB seagate HDD
2x4GB Patriot DDR3 1333MHz Ram
mid tower case
Sapphire Radeon HD 6850
450w PSU

I deduced the problem with no image coming up on the monitor was that the BIOS on the motherboard did not support the Bulldozer processor firmware, since it is somewhat new. I called ASUS and told them the problem, they agreed and sent me a new BIOS hardware with the compatible firmware on it.

I plugged the new BIOS chip into the motherboard, turned it on, and same problem as before; still no image. I've called ASUS multiple times now, gone through all the simple resets and still no solution. The last thing i came upon was that in the motherboard manual, the RAM is not listed as being supported by the motherboard, though not sure how correct that is.

My other best guess is that it's a faulty motherboard, however a friend was impressed with the package deal and bought himself the same thing, except for a different GPU manufacturer. He's experiencing the same problem, though the idea that the motherboard is bad isn't completely out of the question.

Anyone have any ideas? This has literally taken over the last week of my life and all i want to do is make it run. Even my tech savvy friends can't figure this one out.

Anything would be much appreciated, Thanks.