Question New CPU installed PC doesn't start

Jan 22, 2021
2
1
15
0
Hi,
I wanted to upgrate my old CPU from i5-7500 to i7-9700k, both have the same sockets LGA1151 and I checked the motherboard if it's compatible (msi b150 mate) with the new CPU.

If I start the PC the fans start turning and the light that shows that the motherboard gets electricity is shining and after that the PC immediately powers off.

I put in the old CPU checked if the PC still works and it does. After that I did a bios-update and installed the new CPU again with a CMOS reset. Still the same result when trying to start the PC.

What else can I do?

I appreciate any answers and thank you.
 

okjak808

Reputable
Feb 23, 2018
188
25
4,615
6
It appears that the Motherboard you have doesn't support that i7. The reason for this is because of the chipset of your motherboard, when looking for a cpu make sure to search up you Mobo Chipset in this case (B150).

The I7-9700k is a newer CPU and is only compatible with motherboards with these following chipsets.

"H310, B360, H370, Z370, and Z390"

Even others stated that this CPU is not compatible with your MB because of the Chipset.

https://www.reddit.com/r/buildmeapc/comments/c8h00g View: https://www.reddit.com/r/buildmeapc/comments/c8h00g/is_i79700k_compatible_with_b150_gaming_m3_mobo/


https://www.amazon.com/ask/questions/Tx18VHDE2HU43JN/ref=ask_ql_ql_al_hza

Get a motherboard within that chipset range I've typed down earlier in this text, you could sell your current motherboard ans save up for one that supports your i7-9700k.
 
Reactions: Lampi and Mike2009

ASK THE COMMUNITY

TRENDING THREADS

Latest posts