Question New gpu is laggy mouse and movies.

Apr 15, 2019
22
0
10
0
CPU AMD FX-6300 (have the fx 8350 but havent installed it yet due to nervous and waiting for a friend to help)

RAM 16.00GB Single-Channel DDR3 @ 668MHz

Motherboard ASUSTeK M5A97 R2.0

Graphics (OLD) NVIDIA GeForce GTX 750 Ti (EVGA)----------> (NEW ONE) 4096MB ATI Radeon RX 570 Series (ASRock)

PSU Corsair cx750


Storage 111GB KINGSTON SV300S37A120G (SSD)
1TB Western Digital WDC
 

white.a.drew

Respectable
Oct 14, 2017
438
22
1,815
20
Did do a full dump of your old nvidia drivers ie physically do a search in your computers hdd for all old nvidia files and delete them that was my problem it knew the new gpu was running some what alright but disnt seems to work right till i uninstalled deleted ALL OLD AND NEW GPU info Completely then reinstalled new drivers ran beautifully
 
What exactly do you mean by, "laggy mouse and movies" ? Mouse issue ? How does the GPU perform in games ? Do all the games lag as well ? Have you monitored the GPU TEMP as well ?

You should also go for a dual-channel Memory, if possible. Anyways, try using DDU to do a clean install of the GPU drivers. Wipe out all previous traces of the Nvidia drivers. Which OS do you have ?

https://www.guru3d.com/files-details/display-driver-uninstaller-download.html
 
Apr 15, 2019
22
0
10
0
What exactly do you mean by, "laggy mouse and movies" ? Mouse issue ? How does the GPU perform in games ? Do all the games lag as well ? Have you monitored the GPU TEMP as well ?

You should also go for a dual-channel Memory, if possible. Anyways, try using DDU to do a clean install of the GPU drivers. Wipe out all previous traces of the Nvidia drivers. Which OS do you have ?

https://www.guru3d.com/files-details/display-driver-uninstaller-download.html
windows 10 pro and i did a full whipe when i was sure the gpu worked fine
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts