Question New Monitor, sluggish performance, please help

Dec 3, 2019
2
0
10
0
I built a gaming PC last August, and until now I've had absolutely no problems with it. But last week I finally updated from a 60hz to a 240hz monitor because I saw one on sale for a decent price on Amazon. I usually just play Fortnite but sometimes I play other games too. When I switched I was getting like a consistent 150+ FPS all the time but a day or two ago I starting getting below 100 at some points, and I don't understand why. It's not just that either though because when I watch twitch the streams are hitching constantly and I don't think it's my internet because I did a speed test and it said that 140 up and like 40 down and that it's 'very fast.'

RN I'm just doing normal tasks like internet browsing/discord/spotify and it says that my CPU is 8%, 41% and 17% are these normal? When I open Fortnite it say's that my CPU is like 40%, RAM 60% and my GPU usage I can't tell you because now every time I try and open Fortnite it black screens before I can even do anything.

CPU: Ryzen 5 1600
GPU: GTX 1070
RAM: 16gb
250gb SSD

Does anyone know what I can do to fix any of these problems or how to tell what the problem is in the first place?
 
Last edited:
Dec 3, 2019
2
0
10
0
make and model of the psu?
what resolution is the new monitor?
It's a Corsair CX650M (650 watt) and it's 1920x1080. The issue seemed to start when I tried updating the nvidia drivers to the newest 11/26 ones. Should I try to revert back to the drivers before that? Or could it be that my SSD is almost full? I have like 10gb of space left on it.

BTW I fixed the black screen issues but I still kind of have the sluggish performance when watching streams/netflix so I am confused. It's not my internet because it doesn't do this on my phone or smart tv.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS