Question New msi motherboard not recognizing ethernet cable

tchendrickson68

Commendable
Jun 11, 2018
2
0
1,510
0
I just got a few new components that have come with a slew of problems upon installation. I got an MSI b450 tomahawk max, a Ryzen 7 3700, and new ram for the mobo. Everything booted up better than expected, however the system refuses to connect to the internet. I get the error that the ethernet cable is not properly plugged in or broken upon doing windows troubleshooting. I tried the cable with my laptop and it instantly connected so that is not the issue. I've seen many others having similar ethernet troubles with these motherboards so at least I'm not the only one. I've installed all the most recent drivers by downloading them off msi website on my laptop and extracting them via a flash drive. I did the same thing to update the BIOS. In BIOS, the LAN controller is enabled. The ethernet cable is cat 5 (I guess that's a solutions someone had). I believe those were the main solutions I've seen that simply didn't work for me. The cable worked once when I had my case open: it was after I restarted after installing the LAN drivers, then I deleted the zip file and emptied the trash can, and for some reason it came online, most likely a coincidence but still worth noting. I have not been able to replicate that after I had to shut down to put the case together. It's also worth noting that after installing these parts, my PC now has a tendency to be super slow upon startup some times, and I've been getting rather frequent disk boot errors that never occurred before; restarting after will fix it but still it is rather annoying especially after spending hours troubleshooting. For once I would love to upgrade my PC and have everything work fine without having to spend a day fixing something. Any help would be greatly appreciated as I'm at a loss at what to do. I really hope I didn't get a faulty mobo.
 

Obiwancanabi

Proper
Dec 24, 2020
124
25
120
2
you see it in device manager? it says its started properly and the drivers are cool? its a strange one. any indication lights that come on to show its trying anything? you might be able to use your phone sharing the wifi internet, its a short term fix but at a pinch its better than nothing, its either hardware or software, sounds like you have the software checked out :(

The slowing down thing i have no ideas on sorry, it does sound like a nightmare tho, did you do a fresh install of windows?
 

ASK THE COMMUNITY

TRENDING THREADS