Question New PC build - everything turns on, fans work but cant connect monitor

Oct 21, 2020
3
0
10
0
Hi - my 12 year old son has just embarked on building his own pc for gaming. Everything seems to turn on OK - fans light up, things switch on etc (excuse my non technical wording!!) - but he gets a no signal or HDMI cable not found when he tries to connect the monitor. His friend seems to think his parts might not be compatible? These are as below:
  • ASRock B450M Pro4-F AM4 mATX Motherboard
  • AMD Ryzen 3 3100 4 Core Socket AM4 3.6GHz CPU Processor + Wraith Stealth Cooler
  • Deepcool Matrexx 55 Mesh ADD-RGB 4F ARGB Tempered Glass Mid-Tower E-ATX Case
  • Kingston A400 240GB M.2 2280 SSD SA400M8/240G
  • Cooler Master MWE White 650W 80+Power supply
  • Galax NVIDIA GeForce GTX 1650 Super EX 4GB D6 Video
  • Patriot Viper Steel series DDR4 16GB 3200MHz PC4-25600 Dual memory
I have seen the checklist of things to go through which I will direct him to. But in the short term - is there any issue with the components of this build that would prevent a monitor from working? Thank you in advance - much appreciated.
 
Oct 21, 2020
3
0
10
0
Make sure the monitor is connected to the graphics card not the monitor.

The motherboard may need a bios update to work with a 3100. Do you see a "Ryzen 3000 ready" badge on the motherboard box?
Hi - yes the box does say that it is Ryzen 3000 ready - so that's good! Thank you for such a quick response. I will tell my son to make sure the monitor is connected to the graphics card.
 
Oct 21, 2020
3
0
10
0
Make sure the monitor is connected to the graphics card not the monitor.

The motherboard may need a bios update to work with a 3100. Do you see a "Ryzen 3000 ready" badge on the motherboard box?
Just closing this off - all fixed now. The RAM wasn't installed correctly.
 

ASK THE COMMUNITY