Question NEW PC Build with ASUS Prime B660M-A D4 My old 1080TI has no display, blinking power LED every 2 seconds but 3080TI works fine

Jul 16, 2022
2
0
10
0
I am building my friend's son a new gaming PC, and it wouldn't display at boot up. CPU 12400F and Memories are all booting up fine but no display. Power led is blinking every 2 seconds indicating it has trouble with graphic card GTX 1080 TI which is my old one that was lying around.
So I switched GC to my new 3080TI, which boots up fine with 3080TI. then I tried 1080TI on my existing system and it had no problem booting up either

So to summarize,

My computer - Ryzen 3900X, working fine with both 3080TI and 1080TI
New build for my friend's son - Intel 12400F working with 3080TI but has trouble with 1080TI no display.

I know there are no problems with either GPU, and I tried to figure it out for a few days with no luck. Both systems have 850W PSU.

If anyone can help with this issue, my nephew and I will be greatly appreciated it! Thank you so much!
 

Cyberat_88

Distinguished
Apr 9, 2011
1,774
35
19,890
49
So this Brother/Sister friend of yours... (nephew), but I am side tracking.
The new PC that you are building for your nephew works fine with the New GPU.
Where is the problem ?
(Older GPUs will not run in the new PCI-E 4.0 sockets. They are only rated for 3.0.
Backwards compatibility isn't always what they claim it to be.)
 
Jul 16, 2022
2
0
10
0
Yes, my existing computer also has PCI-E 4.0 and works fine with 1080TI and 3080TI
Specs are
AMD Ryzen 9 3900X
Asus ROG Strix X570-E Gaming
DDR4 32GB

But the New system for Nephew won't boot with 1080TI but boots up fine with 3080TI
Intel 12400F (12th Gen)
MSI MAG B660M Mortar WiFi DDR4
DDR4 16GB

I even updated firmware for the 1080TI but no luck.
 

ASK THE COMMUNITY