Question New PC unable to post, please help

Aug 2, 2019
2
0
10
0
Hello,

I'm a first time PC builder (and poster for that matter), and I recently bought components to assemble a new PC for my mother. I've been unable to get a post out of my system after full assembly and can't seem to resolve the matter despite some troubleshooting.

Components:
CPU - Ryzen 5 2600
Motherboard - MSI B450 Tomahawk
RAM - G.Skill Trident RGB 16GB DDR4 3200
GPU - MSI Armor OC RX 570 4GB
Storage - Crucial P1 500GB M.2 SSD
PSU - Silverstone Strider Plus 600W 80+ bronze
Case - Thermaltake Versa J24

On powering on my system, all case fans, CPU fan and GPU fans turn on, and the RGB lights of the RAM, motherboard and case fans light up, however there is no display on my monitor. Initially, the EZ debug light 'BOOT' lit up consistently, and after some online research I tried flashing the latest BIOS for my motherboard. The EZ debug lights now flash briefly, but don't stay lit, however I still am not getting a post. There are no error code beeps when I attempt to boot. I have tried waiting for over 5 minutes as I've heard Ryzen systems can take a while for the initial boot, but I'm still not getting a post.

Other things I've tried without success:
  • ensuring my 24 pin and 4+4 pin power cables are connected to the motherboard
  • attempting to boot with a single stick of RAM, and in different RAM slots
  • reseating my graphics card in the same PCIE slot and the second slot on the motherboard, and ensuring the power cable is attached
  • removing the motherboard from my case and trying to boot on a non-conductive bench
I've otherwise mostly followed this sticky: https://forums.tomshardware.com/threads/perform-these-steps-before-posting-about-post-boot-no-video-problems.1285536/. The only things I haven't done are attempting to clear the CMOS, and reseating the CPU/heatsink. I was anxious about installing the CPU in the first place as I was afraid of bending the CPU pins, so I don't want to redo this if it's not necessary. Also, I tried removing the RAM/GPU and did get the appropriate error code beeps.

One thing I was wondering is if my RAM is possibly incompatible with my motherboard. I didn't check before ordering the RAM, and couldn't find the SKU on the B450 Tomahawk QVL. For what it's worth, the SKU is F4-3200C16D-16GTZR . Could RAM incompatibility be causing this issue?

As I'm a first time builder I don't have any spare components lying around to swap out to test individual components. I was hoping to get some advice prior to spending time and money on getting a technician to have a look at it, or RMAing components.

Many thanks for any help,
Patrick
 
Aug 2, 2019
2
0
10
0
Well after a bit more testing I managed to figure out the problem. I swapped the HDMI cable that was included with the new monitor with a display port cable that I knew worked, and got a post straight away! I feel a little silly for not trying that earlier before disassembling the computer all over again...

I did have one other question which may be really stupid. When I boot into the MSI bios, it seems to be an older layout. Instead of the click bios 5, which to my knowledge is the latest version, I simply reach the 'click bios' with no number next to it (the first version??). There are much fewer options than in the click bios 5, and I don't seem to be able to set an XMP profile amongst other things. I can't seem to find a solution online, does anyone know how to update to the latest click bios version?
 

ASK THE COMMUNITY

TRENDING THREADS