Question Nintendo Switch Pro Controller not detected by Windows 10 ?

Jul 24, 2022
2
0
10
0
My question is almost exactly the same as the one covered in the post "Nintendo Switch Pro controller not detected by Windows 11?" (I even have the same CPU, SSD and PSU) however I am on Windows 10 and there are no answers in that post so I was hoping that maybe posting a question of my own could help with the resolution of the problem.

Basically, my Pro Controller will not connect/be picked up by Windows at all, device manager does not register any new devices and the controller itself does not have its charging light on. The charging light however turns on when my computer boots but switches to a flashing light and then eventually turns off once Windows loads, exactly like in the post I have linked. I have also tried the exact same steps of trying to resolve the issue however none have worked and this problem is especially frustrating.

Connecting the controller via bluetooth is not an option as my motherboard does not have built in bluetooth support. Things I have tried to resolve the problem are as follows:

  • Installing the latest updates available for my system, barring installation of Windows 11
  • Updating the AMD Chipset drivers
  • Using the third party program BetterJoyForCemu to detect the controller (it could not find it)
  • Fully disconnecting the controller from my switch and powering off the switch while trying to connect it to my PC
  • Trying every available port on my motherboard and case to no avail (I know the controller and cable works as they connect fine over USB on my laptop)
If it helps, my PC specs are:

CPU: Ryzen 5 5600x
Motherboard: Asus ROG Strix B550-F Gaming (Non-Wifi)
Ram: GSkill Trident Z RGB 16GB 3200MHz DDR4 CL16
SSD/HDD: Samsung Evo 970 1TB
GPU: GeForce RTX 3060
PSU: Corsair RM 650x 80+ gold
Chassis: NZXT H710
OS: Windows 10 Version 10.0.19043 Build 19043

Any help is much appreciated.
 
Jul 24, 2022
2
0
10
0
My controller has been plugged into the computer since I made this post (about 4 days now) and out of nowhere it just started working, Windows said it was setting up a device and it turned on. Very strange, if anyone knows why or how this could have happened it would be very appreciated if you could respond.
 

ASK THE COMMUNITY

TRENDING THREADS