Question NO AMD GRAPHICS DRIVER INSTALLED

Feb 26, 2020
6
0
10
0
Hey!

So Ive just completed my build and installed all my motherboard drivers. I tried installing my gpu drivers then when done I restart my computer then open up the radeon software, it says NO AMD GRAPHICS DRIVER INSTALLED. Been trying to fix it for the past 3 hours. I uninstalled the drivers with DDU (was in safe mode) and tried reinstalling the drivers. Same problem. I tried updating the motherboard bios, same problem! I even tried uninstalling the drivers from the device manager then using DDU, same thing. I feel like i have tried everything at this point :( Please someone help me, I dont want to spend hundreds on getting this rig repaired at a IT repair shop.

Thanks.

Specs:
Ryzen 3 2200G
Corsair 1x8GB 2400Mhz
B450m Asrock steel legend
Powercolor RX 570 4GB
EVGA 500W

Edit: My integrated Vega 8 graphics work perfectly fine
 
Last edited:
Did you connect the video cable of the monitor to the RX570?

Is the PCIe power cable connected to the RX570?

Reset the BIOS by jumper and power on again

Did you install the RX570 in the upper grey PCIe slot of the motherboard?
 
Feb 26, 2020
6
0
10
0
Did you connect the video cable of the monitor to the RX570?

Is the PCIe power cable connected to the RX570?

Reset the BIOS by jumper and power on again

Did you install the RX570 in the upper grey PCIe slot of the motherboard?
Yes The vidéo cable is connected to the RX 570
The PCIe power cable is connected to the RX 570
The RX 570 is in the PCIe x16 slot
Same problem when the Bios was at version 2.50 (I updated to 2.90)
 

ASK THE COMMUNITY