[SOLVED] No bootable device detected, but SSD is working fine with old system

Oct 26, 2020
2
1
10
0
Hi,

Recently I ordered a new CPU, motherboard and RAM stick for my desktop, using my old SSD that I’ve used for a few years. When I try starting the computer now it goes straight to the UEFI, saying “No boot device detected”. However, the SSD shows up in the Storage section of the UEFI – it just can’t boot from it.

I tried plugging the SSD back into my old CPU and motherboard and it works fine with no issues. Also, I have another SSD with Windows on it that also works with my old CPU and motherboard, and when I try that in the new system it also cannot boot from it (while showing up in the UEFI). I am now fairly certain that the SSD is not the issue, and that either the new motherboard or CPU are faulty, or somehow incompatible with my SSD.

Specifications
CPU: Intel Core i3-10100
Motherboard: ASRock H410M-HDV
RAM: G.Skill Aegis 16 GB DDR4-3200
SSD: Samsung 840 EVO 250 GB
Windows 10

Has anyone run into a problem like this before, where you can’t boot from the storage drive but the storage drive seems to be working fine? If one of the motherboard or CPU are faulty, which is more likely in this case?

Here are some photos of what the UEFI looks like: View: https://imgur.com/a/ccl2AWk
 

ASK THE COMMUNITY

TRENDING THREADS