Question No display and keyboard not working ?

drummerboy0519

Commendable
Nov 22, 2019
13
1
1,515
0
I just build a pc for the first time a couple days ago and although all of the fans spin and lights go up there is no display and the keyboard doesn't work but every other peripheral will work and light up. Can anyone help? There is also a single short beep on boot but sometimes there is no beep. I have got the flash drive for windows 10 and a hard drive plugged in.


Specs -

i7 2600
intel DH67BL motherboard
gtx 1050 ti lp
2x 2gb sticks and 1x 8GB stick
cooler master 500w psu
 
Reactions: Cake62

Nuwan Fernando

Distinguished
Jul 26, 2013
1,131
15
19,965
248
Check whether you have connected the additional power cable to your VGA.

Even then if it doesn't switch on, I would suggest below.

For a start I would suggest you disconnect the VGA, then use a single stick of ram. Connect your monitor to the internal VGA and start the computer to see whether it works.
If so, you can connect all your Rams and try the boot. Finally connect the VGA and see check the same.

This way it would be easy to troubleshoot.
 
Jan 6, 2022
11
0
10
0
Try reconnecting the power cable, turning the power supply off and then on again, and just leaving your PC for like a day and coming back tomorrow. I had this issue like a year ago and it pretty much solved itself /shrug, also, do try checking if the power cable if plugged properly into the electric socket, not just the PC.
 

drummerboy0519

Commendable
Nov 22, 2019
13
1
1,515
0
Check whether you have connected the additional power cable to your VGA.

Even then if it doesn't switch on, I would suggest below.

For a start I would suggest you disconnect the VGA, then use a single stick of ram. Connect your monitor to the internal VGA and start the computer to see whether it works.
If so, you can connect all your Rams and try the boot. Finally connect the VGA and see check the same.

This way it would be easy to troubleshoot.
Hello yes I tried this but problem still there.
 

drummerboy0519

Commendable
Nov 22, 2019
13
1
1,515
0
Try reconnecting the power cable, turning the power supply off and then on again, and just leaving your PC for like a day and coming back tomorrow. I had this issue like a year ago and it pretty much solved itself /shrug, also, do try checking if the power cable if plugged properly into the electric socket, not just the PC.
Hello, I left it for a while but still the same problem occurs.
 

GreyCatz

Distinguished
May 14, 2015
1,156
10
20,465
457
Hello DrummerBoy,

No display and 1 beep usually mean RAM issues:

a) Have you tried booting with only 1 2GB RAM module (as suggested by Nuwan Fernando above)?

b) Your RAM setup is a bit odd, and possibly the cause of your problems. I count a total of 12GBs of RAM. How are the modules seated? 2 - 2 - 8 - 0?

c) Take a closer look at your modules and make sure they conform to the motherboard specifications listed here:
https://www.intel.com/content/www/us/en/support/articles/000006556/boards-and-kits/desktop-boards.html

d) Your chipset and CPU are fairly old (but definitely still OK), but the specific DDR3 requirements for the RAM as defined by Intel must be observed 100 per cent, e.g. DIMM organization.

Cheers,
GreyCatz.
 

ASK THE COMMUNITY