No display on monitor, lights on

untechie

Distinguished
Jul 27, 2011
1
0
18,510
Hello, this is my first build. Using the bare minimum of components needed to run, my monitor still fails to display anything.

I'm not sure if I did anything wrong or did not realize if there was an extra step I was suppose to take. I plug in the motherboard power with the 4 pin right next to it.
Plugged in another 4 pin next to where it says military class. Popped in the CPU. Plugged in the GFX card along with the monitor adapter. With the case Power SW, plugged the 2 pin adapter into the corresponding spot designated. the green for positive and the black for ground. The lights go on at the top, in the manual it indicated that the CPU is in 2 phase power mode. There's still no display though, not even the BIOS screen.

I took some steps to check which parts work or not. The videocard works, because I plugged in this computer and everything displayed correctly, except that I needed to install the drivers. Then I swapped the PSU with another one that works properly (because I used it before), Antec 430 watt but still the same results. I have not checked the RAM because I honestly believed that both of them would not fail on me. I cannot check the CPU because I do not have another AMD mobo. Plugging in the HD works in my other computer, requiring me to boot from disc.


Additionally, I tried inserting the drivers disc into my sony cd/dvd reader drive turned off the power, and restarted, There's still nothing on the screen.
Also holding the power button doesn't turn off the mobo.

Can someone shed a little light on my problem. I have pictures of what everything looks like, kinda provided below.
http://i64.photobucket.com/albums/h168/Aerialz/mobo/DSCN0236.jpg
http://i64.photobucket.com/albums/h168/Aerialz/mobo/DSCN0237.jpg
http://i64.photobucket.com/albums/h168/Aerialz/mobo/DSCN0239.jpg
http://i64.photobucket.com/albums/h168/Aerialz/mobo/DSCN0241.jpg
http://i64.photobucket.com/albums/h168/Aerialz/mobo/DSCN0242.jpg
http://i64.photobucket.com/albums/h168/Aerialz/mobo/DSCN0243.jpg
http://i64.photobucket.com/albums/h168/Aerialz/mobo/DSCN0247.jpg A closer look at the lights, doesn't really help though I think.


Motherboard: MSI 890FXA-GD65 for AMD processors
Graphics Card: MSI Radeon 5770
CPU: AMD Phenom II X6 1055T Thuban
PSU: APEVIA ATX-CW500WP4 500watt
RAM: ADATA XPG Gaming Series 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600
HD: SAMSUNG Spinpoint F3 HD103SJ
Heatsink if needed: XIGMATEK Gaia SD1283
 

jamie_1318

Distinguished
Jun 25, 2010
188
0
18,710
Just thought I'd chip in. If nothing is happening after you have run through the guide, double check the power switch plugs on the motherboard, those cause problems for most people on the first try (or first couple tries).