[SOLVED] No display

Jul 11, 2019
2
1
15
0
Hi,

I need some help. I am a noob when it comes to building a computer, so for the last 6 months, I have been watching a lot of videos on how to build a computer, and I finally purchased all the components and just I finished building my PC. But, unfortunately even with all the research I did about how to this, which I thought I knew what I was getting myself into, I am having an issue.

The issue is that I plugged everything in, and I get no signal on my monitor, I tried it on my TV (HDMI), nothing. Inside the case everything seems to be running, the fans are on, I see a few LEDs on , the mouse is on, the Leds on the RAM are on ... The computer seems to be running.

Here are my specs:
  • Cooler Master MasterBox Q300L mATX
  • ASRock B450M Steel Legend AM4 AMD Promontory B450 SATA 6Gb/s USB 3.1 HDMI Micro ATX AMD Motherboard
  • AMD RYZEN 5 1600 6-Core 3.2 GHz (3.6 GHz Turbo) Socket AM4 65W YD1600BBAEBOX Desktop Processor
  • G.SKILL TridentZ RGB Series 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4 25600) Desktop Memory Model F4-3200C16D-16GTZR
  • WD Blue 3D NAND 500GB Internal SSD - SATA III 6Gb/s 2.5"/7mm Solid State Drive - WDS500G2B0A
  • Cooler Master MWE Gold 650 Watt Fully Modular, Compact, Silent Fan 80 PLUS Gold Power Supply
So my thought process was to get this motherboard because it has "Integrated AMD Radeon Vega Series Graphics in Ryzen Series APU* "
and I thought I will wait a bit before buying a decent Graphic card.

Now it seems that the "Actual support may vary by CPU" according to the motherboard description.
So, I looked at my CPU specs and It turns out : "Discrete GPU Required - No Integrated Graphics"

I thought this might be the issue.

So I went ahead, and just ordered a graphic card : GIGABYTE GeForce GTX 1660 Ti OC 6G Graphics Card, 2 x WINDFORCE Fans, 6GB 192-Bit GDDR6, GV-N166TOC-6GD Video Card
which I haven't received yet.

But, after second thought, shouldn't I be able to have access at least to the BIOS even if I didn't have any graphic card.

I am now worried, that once I received my graphic card, this might not solved my issue of having no display.


Any thoughts?

Thanks in advance.
 

ASK THE COMMUNITY