Question No internet connection after uninstalling "Windows Live ID sign-in Assistant" and deleting it manually from "services" and the registry.

stookza

Reputable
Jan 23, 2019
23
3
4,515
0
Hi

I need help please after uninstalling yesterday "Windows Live ID sign-in Assistant", removing it manually from "services" [with Gmer] and deleting everything that related to it [Wlidsvc,exe] from the registry.

As a result of it, i lost my internet connection [despite that the network card and "local area connection" appear as enabled], also i cannot open some softwares like "Ccleaner" and others.

Tried to do system restore after the mistake, but unfortunately i didnt have any restore points because i did files cleaning with some programs few minutes before :-(

Will really appreciate for some help asap because i use this pc as my 2nd to my main pc.

Many thanks
 
Last edited:

stookza

Reputable
Jan 23, 2019
23
3
4,515
0
No i didnt backup my o.s and i dont have any previous restore point unfortunately :-(

The only 1 backup i have is the files inside "config"---> "RegBack" folder in "system32" since 2 years ago when i installed windows and maybe ill replace them with the current ones as a last resort but i really dont wanna do that.
 
Last edited:
No i didnt backup my o.s and i dont have any previous restore point unfortunately :-(

The only 1 backup i have is inside "config"---> "RegBack" folder in "system32" since 2 years ago when i installed windows and maybe ill replace them with the current ones as a last resort but i really dont wanna do that.
That's a pity!

Try an in place install of Windows (Reset PC), it will keep your existing files and apps, and will hopefully reset the registry.
 

stookza

Reputable
Jan 23, 2019
23
3
4,515
0
Many thanx for the the advice Roland (y) but i finally fixed it by doing what i suggested in my previous massage, and simply copied the files inside: "System32--->config--->RegBack" folder and replaced them with the files that located inside "System32--->config", and now everything is back :giggle: , the internet connection, and all the programs i guess working again without the need to reinstall them, only minor settings had to be reconfigured, like some netowrk settings that have changed [dns and ip address] in Local area connection tcp/ip version 4 and Eset nod32 anti virus had to be registered from some reason again... and also reupdated to the latest version. but Im so glad now :D

But i still wonder and dont really understand why the "Windows Live ID Sign-in Assistant" registry files are so important and essential to the operating system to work well, and must be installed [but not be enabled] in order to have a working internet connection and other related programs which will simply not work if i erase the damn thing from the registry and "services".

This thread can be marked as solved :)
 
Last edited:
Reactions: Roland Of Gilead
Many thanx for the the advice Roland (y) but i finally fixed it by doing what i suggested in my previous massage, and simply copied the files inside: "System32--->config--->RegBack" folder and replaced them with the files that located inside "System32--->config", and now everything is back :giggle: , the internet connection, and all the programs i guess working again without the need to reinstall them, only minor settings had to be reconfigured, like some netowrk settings that have changed [dns and ip address] in Local area connection tcp/ip version 4 and Eset nod32 anti virus had to be registered from some reason again... and also reupdated to the latest version. but Im so glad now :D

But i still wonder and dont really understand why the "Windows Live ID Sign-in Assistant" registry files are so important and essential to the operating system to work well, and must be installed [but not be enabled] in order to have a working internet connection and other related programs which will simply not work if i erase the damn thing from the registry and "services".

This thread can be marked as solved :)
Excellent, that's a result :) That's good that you caught the issue. In the past I've often made little mistakes, and then suddenly get an epihany of how to fix it (always late in the morning :tearsofjoy: )

Glad it's sorted. If you have other issues, you can always come back to us for advice.
 

ASK THE COMMUNITY