No two finger-tap to right click in Windows 8.1?

DonQuixoteMC

Distinguished
Sep 19, 2011
1,532
0
20,460
228
Just a problem I'm having. Before the 8.1 update, I could tap with two fingers to right click. Now I have to use the right click button. Any ideas?

I uninstalled, then installed the latest drivers for my touchpad, and checked the touchpad settings. Nothing.

And if I'm posting this in the wrong forum, please show me the error in my ways.

Thanks.

DonQuixoteMC
 

woojoo666

Honorable
Nov 2, 2013
1
0
10,520
1
Found the solution here, reprinted and slightly edited for convenience:

1. To manually re-enable two finger tap, hit windows key + r, enter "regedit" then hit enter, and on the left pane browse to the following location:

HKEY_CURRENT_USER\Software\Synaptics\SynTP\TouchPadPS2

2. In the right pane double click on 2FingerTapAction and change the value to a "2" for right click, or a "4" for middle click (I use 2). Also double click on 2FingerTapPluginID and clear any value it may have.

3. Next in the right pane, find the MultiFingerTapFlags key and change it from a 2 to a 3

4. As a bonus, if you want to enable three finger tap for middle click, double click on 3FingerTapAction and change the value to a "4", also clear any value for 3FingerTapPluginID and set 3FingerTapPluginActionID to "0".
 

aidanklenk

Honorable
Jul 9, 2012
214
0
10,760
27
this is a windows 8.1 issue. there are a lot of people having it.
the only fix i can think of would be to follow the steps on this link.

http://www.intowindows.com/how-to-enable-two-finger-tap-for-right-click-in-windows/
 

DonQuixoteMC

Distinguished
Sep 19, 2011
1,532
0
20,460
228


I figured it had to be. Thanks for the confirmation.

That's a good idea to use a third party workaround until the actual fix. Thanks a lot!

DonQuixoteMC

 

woojoo666

Honorable
Nov 2, 2013
1
0
10,520
1
Found the solution here, reprinted and slightly edited for convenience:

1. To manually re-enable two finger tap, hit windows key + r, enter "regedit" then hit enter, and on the left pane browse to the following location:

HKEY_CURRENT_USER\Software\Synaptics\SynTP\TouchPadPS2

2. In the right pane double click on 2FingerTapAction and change the value to a "2" for right click, or a "4" for middle click (I use 2). Also double click on 2FingerTapPluginID and clear any value it may have.

3. Next in the right pane, find the MultiFingerTapFlags key and change it from a 2 to a 3

4. As a bonus, if you want to enable three finger tap for middle click, double click on 3FingerTapAction and change the value to a "4", also clear any value for 3FingerTapPluginID and set 3FingerTapPluginActionID to "0".
 

DonQuixoteMC

Distinguished
Sep 19, 2011
1,532
0
20,460
228


Nicely done!

I'll make the changes next chance I get! Not that the third-party solution hasn't been treating me well, I'm just a stickler about keeping a small startup load. haha

DonQuixoteMC
 

Cenryk

Honorable
Nov 21, 2012
3
0
10,510
0
Sorry to post on an old thread, but could it be your settings in the touchpad profile got reset? I'm using 8.1 and I never had the problem, though my manager has a similar laptop but his two finger tap is set to highlight instead of right click. Just a thought, hopefully any future lurkers might try to check the settings before going through regedit.
 

DonQuixoteMC

Distinguished
Sep 19, 2011
1,532
0
20,460
228


It wasn't, it was just an early bug when Windows 8.1 was first released.

Now though, the registry edit is unnecessary, and your solution should be the one that people try first!
 

Rulo Campos

Reputable
Mar 1, 2014
2
0
4,520
1
FOUND IT! solution to right click.

There is no real problem. The thing is that now one has to PRESS (click) the touchpad on any place with the two fingers. I found it by accident. I have HP and windows 8.1.

CHeers!





 

Nocke

Reputable
Mar 16, 2014
1
0
4,510
0


I have a Lenovo U510 and also had to do the changes in

"HKEY_CURRENT_USER\Software\Synaptics\SynTP\TouchPadPS2"
AND
"HKEY_CURRENT_USER\Software\Synaptics\SynTP\TouchPadSMB2c"

At last I´ve my missing two-finger-tap back :D

Thanks a lot guys! ;)

KCCO,
Nocke
 

Sunny Prasad

Reputable
Dec 12, 2014
1
0
4,510
0
Go to Start > Run and type Regedit in Windows 7, or in Windows 8 type Regedit at the start screen.

Once open navigate to:

HKEY_CURRENT_USER > Software > Synaptics > SynTP > TouchpadPS2

There, right click and select New, DWORD Value. Name the value '2FingerTapAction'. Once created, double click it and set the Value Data to '2'.

If '2FingerTapAction' is already there, double click it and set the Value Data to '2'.

Then log off and log on, and it should all work. Easy.
 

EmSeeAjnar

Reputable
Jan 8, 2015
1
0
4,510
0
When get into this, theres several "ActionIDX" , x going from 1-7, to choose. all with default values. only one is without, and thats called (Standard). what to do?

Also, should you choose hexi- or decimal numbers, for the values?
 

David Villarroel

Reputable
Jan 31, 2015
1
0
4,510
0
I have the same problem but the solution that found was in some way ridicule....
ok all of you just need to type in google the full name of the model for the laptop like this "hp envy touchsmart m7-j078ca"
go in on the first page of hp and select the OS (windows 8.1) and download the touchpad driver then uninstall your current version and install your download, that's all
thats works for me and for other 3 guys that i know
 

Zexi Zhuang

Reputable
Jul 24, 2015
1
0
4,510
0


The registry fix did work but somehow I had to double tap two fingers and one single tap of two fingers did not work. I have lenovo G50 laptop.
 

ASK THE COMMUNITY

TRENDING THREADS